ID: 27321
Comment by: ibaldo at esquemas dot com
Reported By: jg at execulink dot com
Status: Feedback
Bug Type: Apache related
Operating System: Redhat Linux 7.3
PHP Version: 4.3.5RC3
New Comment:
With Fedora Core 1, php-4.3.4-1.1 and httpd-2.0.48-1.2 we are
experiencing the exact same problem with open_basedir.
Settings of open_basedir are being reflected in other vhosts that
doesn't specify an open_basedir!
To reproduce the problem we accesed continuosly to a vhost that has the
open_basedir set, and simultaneusly we accesed continuosly a vhost
without the open_basedir, and the open_basedir of the first was
sometimes applied to the second vhost mentioned, trying diferent vhosts
which had the basedir and others that don't, we seen that the first was
applied to the second in accordance to the hosts being tested at that
particular time!
This is not a configuration problem as someone mentions but clearly a
nasty bug.
If someone gets an specific patch for this that could be tested in a
production environment then please contact us.
Thank you guys!
Previous Comments:
------------------------------------------------------------------------
[2004-02-25 08:09:29] sniper@php.net
Please try using this CVS snapshot:
http://snaps.php.net/php4-STABLE-latest.tar.gz
For Windows:
http://snaps.php.net/win32/php4-win32-STABLE-latest.zip
------------------------------------------------------------------------
[2004-02-25 08:08:59] jg at execulink dot com
Actually this is not a configuration problem, since the open_basedir
it's complaining about is NOT the one I have configured for that vhost.
------------------------------------------------------------------------
[2004-02-24 17:12:12] sniper@php.net
This is some configuration failure on user's side:
File(/usr/ppp/p/pookie/public_html/index.php) is not within the allowed
path(s): (/usr/ppp/p/pdipietro) in Unknown on line 0
(this is perfectly valid and expected error when you try to access file
outside the open_basedir..)
------------------------------------------------------------------------
[2004-02-20 08:06:22] jg at execulink dot com
I'm using Apache/1.3.27 (Unix) (Red-Hat/Linux)
I've already tried running this snapshot:
php4-STABLE-200402191630 with no luck.
------------------------------------------------------------------------
[2004-02-19 13:57:04] jg at execulink dot com
Description:
------------
INI Settings, specificially open_basedir seems to be leaking between
apache virtualhost settings. Bug seems to be very similar to #25753,
but was not resolved for me in 4.3.5RC3.
e.g., One user - pookie's php fails with the following error:
(pdipietro is another user on the system, in another virtualhost).
I would really appreciate either a workaround, patch, or fix!
phpinfo(); PHP Version 4.3.5RC3
Warning: Unknown(): open_basedir restriction in effect.
File(/usr/ppp/p/pookie/public_html/index.php) is not within the
allowed
path(s): (/usr/ppp/p/pdipietro) in Unknown on line 0
Warning: Unknown(/usr/ppp/p/pookie/public_html/index.php): failed to
open stream: Operation not permitted in Unknown on line 0
Warning: (null)(): Failed opening
'/usr/ppp/p/pookie/public_html/index.php' for inclusion
(include_path='.:/usr/share/pear') in Unknown on line 0
------------------------------------------------------------------------
--
Edit this bug report at http://bugs.php.net/?id=27321&edit=1