#27751 [Bgs->Csd]: Apache2 2.0.49 crash when restarting (PHP4.3.5 only, works fine in 4.3.4)
| From: | packager at rabbito dot org | Date: | Thu, 01 Apr 2004 10:41:29 +0000 |
| Subject: | #27751 [Bgs->Csd]: Apache2 2.0.49 crash when restarting (PHP4.3.5 only, works fine in 4.3.4) | ||
| References: | 1 | Groups: | php.bugs |
| Request: | Send a blank email to php-bugs+get-57311@lists.php.net to get a copy of this message | ||
ID: 27751
User updated by: packager at rabbito dot org
Reported By: packager at rabbito dot org
-Status: Bogus
+Status: Closed
Bug Type: Apache2 related
Operating System: Windows XP
PHP Version: 4.3.5
New Comment:
Please refer to:
http://bugs.php.net/bug.php?id=27810
Previous Comments:
------------------------------------------------------------------------
[2004-03-30 23:59:57] josestefan at hotmail dot com
sorry, my report is wrong. I forgot that the error occurs after the
first php request, when I did my testing.
------------------------------------------------------------------------
[2004-03-30 22:45:49] josestefan at hotmail dot com
I've noticed that disabling all CustomLog in apache's httpd conf file
avoids the crash. So maybe that's a good place for the developers to
start looking.
I have log_errors = Off on my php.ini file, so it really doesn't make
sense to me. But I have confirmed that with the CustomLogs disabled, I
get no crashes.
------------------------------------------------------------------------
[2004-03-29 10:46:29] iliaa@php.net
Please do not submit the same bug more than once. An existing
bug report already describes this very problem. Even if you feel
that your issue is somewhat different, the resolution is likely
to be the same.
Thank you for your interest in PHP.
Dupe of bug #27735
------------------------------------------------------------------------
[2004-03-29 08:23:35] packager at rabbito dot org
The crash only occur after the first PHP script is executed, ie)
someone requested a url that is generated by PHP.
Uses standard php.ini file and a slightly modified httpd.conf file with
the following lines added:
LoadModule php4_module C:\www\php\sapi\php4apache2.dll
AddType application/x-httpd-php .php
------------------------------------------------------------------------
[2004-03-29 08:20:09] packager at rabbito dot org
Description:
------------
Apache2 2.0.49 crash when restarting Apache2 from Apache Service
Monitor under PHP4.3.5
Works fine (no crash) with PHP-4.3.4, Apache2.0.49.
Expected result:
----------------
Apache2 should exit without application error
Actual result:
--------------
The following Apache Application Error occurs
---------------------------------------------
The instruction at "0x77f83aed" referenced memory at "0x37412d32". The
memory could not be "written".
Click on OK to terminate the program
Click on CANCEL to debug the program
------------------------------------------------------------------------
--
Edit this bug report at http://bugs.php.net/?id=27751&edit=1