Bug #13595 Updated: Solution for "PHP Fatal error: Unable to start session mm module in Unknown on
| From: | 2002 at gabrielwicke dot de | Date: | Wed, 24 Apr 2002 21:15:48 +0000 |
| Subject: | Bug #13595 Updated: Solution for "PHP Fatal error: Unable to start session mm module in Unknown on | ||
| References: | 1 | Groups: | php.bugs |
| Request: | Send a blank email to php-bugs+get-5881@lists.php.net to get a copy of this message | ||
ID: 13595
Updated by: 2002@gabrielwicke.de
Reported By: plafundum@yahoo.com
Status: Analyzed
Bug Type: Session related
Operating System: Debian Sid
PHP Version: 4.0.6
New Comment:
I'm experiencing a similar problem after updating to php 4.1.0-104
(from the SUSE 8.0 Distro). Whenever i try to call php as a cgi ftp
server i now get this:
Content-type: text/html
PHP Fatal error: Unable to start session mm module in Unknown on line
0
i did a locate .sem and it showed one file at
/var/lib/httpd/mm.1257.sem. Deleting that didn't help.
The ftp loader worked perfect with the previous version (4.0something),
and the trouble with the new version appears only when calling php as
cgi.
Any ideas?
Previous Comments:
------------------------------------------------------------------------
[2002-03-07 15:08:30] matt@mystile.com
Yes, I had the save path explicitly set to '/dev/null' in php.ini since
I first installed version 4.0.5; I haven't been using sessions, so I
wouldn't have noticed if sessions were not working. However, after the
upgrade, I sure noticed something was wrong, since apache wouldn't
start.
As for why it was setup that way... I have the server setup so each
virtual host uses its own 'tmp' directory, and as I recall, I didn't
want PHP to store anything in '/tmp'.
------------------------------------------------------------------------
[2002-03-07 00:30:14] mfischer@php.net
Ah .. interesting ...
Did you set the save path explicitely to '/dev/null' ? (And if so,
why?)
All I know at the moment is that serveral session issues are adressed
at the moment. Marking this as analyzed until one of our session gurus
can answer this more accurat.
------------------------------------------------------------------------
[2002-03-06 19:50:16] matt@mystile.com
Thanks to mfischer@php.net, I found the problem using strace. I had
'session.save_path' set to '/dev/null'.
Why does 4.1.2 not handle this gracefully like 4.0.5, and is there any
way to get a more helpful error message in this case?
In case you're interested in the exact errors, I've included the errors
from the strace below:
unlink("/dev/null/session_mm_apache0.sem") = -1 ENOTDIR (Not a
directory)
open("/dev/null/session_mm_apache0.sem", O_RDWR|O_CREAT, 0600) = -1
ENOTDIR (Not a directory)
unlink("/dev/null/session_mm_apache0.sem") = -1 ENOTDIR (Not a
directory)
------------------------------------------------------------------------
[2002-03-05 02:24:42] mfischer@php.net
An other alternative would be to use use 'strace' on the apache process
(make sure you start apache with -X switch), maybe you can gather where
it has failed, e.g.
strace -e trace=file -o output /usr/sbin/apache -X
and see in file 'output' what fails.
------------------------------------------------------------------------
[2002-03-05 02:17:02] derick@php.net
Can you try a snapshot from snaps.php.net? It might be fixed, if not we
need feedback on that branch anyways.
regards,
Derick
------------------------------------------------------------------------
The remainder of the comments for this report are too long. To view
the rest of the comments, please view the bug report online at
http://bugs.php.net/13595
--
Edit this bug report at http://bugs.php.net/?id=13595&edit=1