#28362 [Opn->Fbk]: Receiving 500 error when uploading file.
ID: 28362
Updated by: iliaa@php.net
Reported By: chris at komodohost dot com
-Status: Open
+Status: Feedback
Bug Type: Apache related
Operating System: RedHat Enterprise Linux 3
PHP Version: 4.3.6
New Comment:
Does the error occur if you compile PHP without
--enable-discard-path?
Previous Comments:
------------------------------------------------------------------------
[2004-05-11 23:51:32] chris at komodohost dot com
Ok, dropped the --enable-versioning option. The Apache log shows the
dreaded "Premature end of script headers" error.
------------------------------------------------------------------------
[2004-05-11 23:12:32] derick@php.net
What shows in your Apache error log?
(Also, drop the --enable-versioning option to ./configure).
------------------------------------------------------------------------
[2004-05-11 21:00:46] chris at komodohost dot com
Still getting the same error after upgrading.
------------------------------------------------------------------------
[2004-05-11 20:26:08] iliaa@php.net
Please try using this CVS snapshot:
http://snaps.php.net/php4-STABLE-latest.tar.gz
For Windows:
http://snaps.php.net/win32/php4-win32-STABLE-latest.zip
------------------------------------------------------------------------
[2004-05-11 20:21:11] chris at komodohost dot com
Description:
------------
Receiving Internal Server Error on any form posted which contains an
uploaded file. We are running PHP with PHPSuExec. File has correct
ownership and permissions. PHP was configured with:
'./configure' '--prefix=/usr' '--with-xml' '--enable-bcmath'
'--enable-calendar' '--with-curl' '--enable-ftp' '--with-gd'
'--with-jpeg-dir=/usr/local' '--with-png-dir=/usr'
'--with-xpm-dir=/usr/X11R6' '--with-mcrypt' '--with-mhash'
'--enable-magic-quotes' '--with-mysql' '--enable-discard-path'
'--with-pear' '--enable-sockets' '--enable-track-vars'
'--enable-versioning' '--with-zlib'
Reproduce code:
---------------
<?php
// Sample available at: http://www.komodohost.com/uploadbug.php
if ($_POST[file1]) {
echo "Success!";
}
?>
<form enctype="multipart/form-data" method="POST">
<input type="file" name="file1" size="48">
<input type="submit" value="Continue">
</form>
Expected result:
----------------
Upon posting form, "Success!" should be displayed.
Actual result:
--------------
500 Internal Server Error
------------------------------------------------------------------------
--
Edit this bug report at http://bugs.php.net/?id=28362&edit=1
Thread (9 messages)