#28677 [NEW]: libphp4.so: symbol ber_flush: referenced symbol not found
| From: | dhaval dot choksi at in dot iqara dot net | Date: | Mon, 07 Jun 2004 17:38:55 +0000 |
| Subject: | #28677 [NEW]: libphp4.so: symbol ber_flush: referenced symbol not found | ||
| Groups: | php.bugs | ||
| Request: | Send a blank email to php-bugs+get-60513@lists.php.net to get a copy of this message | ||
From: dhaval dot choksi at in dot iqara dot net
Operating system: Solaris 9
PHP version: 4.3.6
PHP Bug Type: Apache related
Bug description: libphp4.so: symbol ber_flush: referenced symbol not found
Description:
------------
I am successfull configured make and make install php-4.2.2 with apache
webserver version 1.3.26 but when i am trying to start apache i m getting
the below errow
bash-2.03# ./apachectl start
Syntax error on line 222 of /usr/local/apache/conf/httpd.conf:
Cannot load /usr/local/apache/libexec/libphp4.so into server: ld.so.1:
/usr/local/apache/bin/httpd: fatal: relocation error: file
/usr/local/apache/libexec/libphp4.so: symbol ber_flush: referenced symbol
not found
./apachectl start: httpd could not be started
-------------php config command------------------------
./configure --prefix=/usr/local/php4.2.2
--with-apxs=/usr/local/apache/bin/apxs
--with-ldap
--with-oci8=/export/home/oracle/
--with-gdbm
--with-zlib
--enable-calendar
--enable-bcmath
--enable-filepro --enable-track-vars
--enable-force-cgi-redirect
--enable-libgcc
configure make and make install are successfull. In one of the post here
only i read to add "--enable-libgcc" and --with-zlib which i did but there
was no success. I have gcc-3.3.2. If you need any other information please
ask.
Thanks
Dhaval Choksi
Expected result:
----------------
Apache and php should run
--
Edit bug report at http://bugs.php.net/?id=28677&edit=1
--
Try a CVS snapshot (php4): http://bugs.php.net/fix.php?id=28677&r=trysnapshot4
Try a CVS snapshot (php5): http://bugs.php.net/fix.php?id=28677&r=trysnapshot5
Fixed in CVS: http://bugs.php.net/fix.php?id=28677&r=fixedcvs
Fixed in release: http://bugs.php.net/fix.php?id=28677&r=alreadyfixed
Need backtrace: http://bugs.php.net/fix.php?id=28677&r=needtrace
Need Reproduce Script: http://bugs.php.net/fix.php?id=28677&r=needscript
Try newer version: http://bugs.php.net/fix.php?id=28677&r=oldversion
Not developer issue: http://bugs.php.net/fix.php?id=28677&r=support
Expected behavior: http://bugs.php.net/fix.php?id=28677&r=notwrong
Not enough info: http://bugs.php.net/fix.php?id=28677&r=notenoughinfo
Submitted twice: http://bugs.php.net/fix.php?id=28677&r=submittedtwice
register_globals: http://bugs.php.net/fix.php?id=28677&r=globals
PHP 3 support discontinued: http://bugs.php.net/fix.php?id=28677&r=php3
Daylight Savings: http://bugs.php.net/fix.php?id=28677&r=dst
IIS Stability: http://bugs.php.net/fix.php?id=28677&r=isapi
Install GNU Sed: http://bugs.php.net/fix.php?id=28677&r=gnused
Floating point limitations: http://bugs.php.net/fix.php?id=28677&r=float