#28677 [Opn->Fbk]: libphp4.so: symbol ber_flush: referenced symbol not found
| From: | magnus@php.net | Date: | Tue, 08 Jun 2004 00:52:51 +0000 |
| Subject: | #28677 [Opn->Fbk]: libphp4.so: symbol ber_flush: referenced symbol not found | ||
| References: | 1 | Groups: | php.bugs |
| Request: | Send a blank email to php-bugs+get-60531@lists.php.net to get a copy of this message | ||
ID: 28677
Updated by: magnus@php.net
Reported By: dhaval dot choksi at in dot iqara dot net
-Status: Open
+Status: Feedback
Bug Type: Apache related
Operating System: Solaris 9
PHP Version: 4.3.6
New Comment:
Please try using this CVS snapshot:
http://snaps.php.net/php4-STABLE-latest.tar.gz
For Windows:
http://snaps.php.net/win32/php4-win32-STABLE-latest.zip
Previous Comments:
------------------------------------------------------------------------
[2004-06-07 19:38:54] dhaval dot choksi at in dot iqara dot net
Description:
------------
I am successfull configured make and make install php-4.2.2 with apache
webserver version 1.3.26 but when i am trying to start apache i m
getting the below errow
bash-2.03# ./apachectl start
Syntax error on line 222 of /usr/local/apache/conf/httpd.conf:
Cannot load /usr/local/apache/libexec/libphp4.so into server: ld.so.1:
/usr/local/apache/bin/httpd: fatal: relocation error: file
/usr/local/apache/libexec/libphp4.so: symbol ber_flush: referenced
symbol not found
./apachectl start: httpd could not be started
-------------php config command------------------------
./configure --prefix=/usr/local/php4.2.2
--with-apxs=/usr/local/apache/bin/apxs
--with-ldap
--with-oci8=/export/home/oracle/
--with-gdbm
--with-zlib
--enable-calendar
--enable-bcmath
--enable-filepro --enable-track-vars
--enable-force-cgi-redirect
--enable-libgcc
configure make and make install are successfull. In one of the post
here only i read to add "--enable-libgcc" and --with-zlib which i did
but there was no success. I have gcc-3.3.2. If you need any other
information please ask.
Thanks
Dhaval Choksi
Expected result:
----------------
Apache and php should run
------------------------------------------------------------------------
--
Edit this bug report at http://bugs.php.net/?id=28677&edit=1