#29154 [Com]: Exif extension not loading with PHP 5
ID: 29154
Comment by: me at localhost dot de
Reported By: scm2tj at cs dot cf dot ac dot uk
Status: Open
Bug Type: PHP options/info functions
Operating System: W2K
PHP Version: 5.0.0
New Comment:
To enable exif support in Windows, php_mbstring.dll must be loaded
prior to php_exif.dll in php.ini.
Previous Comments:
------------------------------------------------------------------------
[2004-07-15 03:30:44] scm2tj at cs dot cf dot ac dot uk
Enabling mbstring didn't help, for some reason it caused Apache to stop
working completely. It didn't give any error messages, but wouldn't
accept any request unless it was restarted with the mbstring module in
the php.ini disabled.
I also tried moving the dll files to the winnt\system32 directory, but
that didn't help. I also put the PHP\ext directory in the PATH, and
that did nothing either.
I'm using the gd2, sockets, and gettext libraries without any problems,
and I'm 100% all the files are in the correct place.
------------------------------------------------------------------------
[2004-07-14 21:14:17] helly@php.net
If you're sure that you have downloaded the exif dll into the right
place check if you also enabled module mbstring.
------------------------------------------------------------------------
[2004-07-14 17:42:38] christian at wenz dot org
might be the same as http://bugs.php.net/bug.php?id=29028 (however the
"resolution" there does not state which extra libraries are the ones
missing).
Can reproduce on two IIS servers on Win XP, as well, so it may be a
general problem on Windows.
Maybe also related to http://bugs.php.net/bug.php?id=29131 (?)
------------------------------------------------------------------------
[2004-07-14 16:22:12] scm2tj at cs dot cf dot ac dot uk
Description:
------------
With the exif extension permitted in the php.ini file, a reboot of
Apache 2 gives an error stating
Cannot load C:/PHP/ext/php_exif.dll into server. The specified module
could not be found
PHP 4 worked fine, but 5 RC3 and 5.0.0 don't (I didn't try earlier
versions).
Needless to say, other extensions I've permitted have worked fine, so
it's not a problem with my php.ini file
------------------------------------------------------------------------
--
Edit this bug report at http://bugs.php.net/?id=29154&edit=1
Thread (6 messages)