#21522 [Com]: Ldap unable to load - module not found
| From: | aleibman at dawork dot com | Date: | Wed, 11 Aug 2004 03:08:19 +0000 |
| Subject: | #21522 [Com]: Ldap unable to load - module not found | ||
| References: | 1 | Groups: | php.bugs |
| Request: | Send a blank email to php-bugs+get-64388@lists.php.net to get a copy of this message | ||
ID: 21522
Comment by: aleibman at dawork dot com
Reported By: bool at gte dot net
Status: Bogus
Bug Type: LDAP related
Operating System: Windots NT
PHP Version: 4.3.0
New Comment:
As a result of all extensive reading I got php_mysql.dll in four places
already:
C:\WINNT\system32
C:\WINNT\
C:\php
C:\php\ext
I uncomented
extension_dir = "./PHP"
and
extension=php_mysql.dll
BUT I am still getting:
PHP Startup: Unable to load dynamic library './PHP\php_mysql.dll'-...
I played with extension_dir changing it to something like
"C:/php/ext"
BUT this does not help.
Could you please help?
Thank you aleibman@dawork.com
Previous Comments:
------------------------------------------------------------------------
[2003-01-09 08:53:19] bool at gte dot net
I fell like a dolt now... I copied the files and everything is working
like a charm. Thank you very much for the help.
------------------------------------------------------------------------
[2003-01-08 17:51:14] edink@php.net
You probably missed a part in the install intructions about copying
dlls\*.dll to c:\winnt\system32.
------------------------------------------------------------------------
[2003-01-08 12:46:16] bool at gte dot net
When attempting to enable the extension php_ldap.dll from the 4.3.0
windows binary build I first copied the dll to c:\php\, set the proper
variable in php.ini to tell php to look for extensions in c:\php and
uncommented the line extension=php_ldap.dll. save, shutdown iis,
restart to get an error telling me that module c:\php\php_ldap.dll is
not found and there is a refrence to function Unknown().
After verifying that I did not screw up my copy job and the file
c:\php\php_ldap.dll DID exist I came back to the site and did a serch
for others having the same problem. In 2001 there were many refrences
to the same error and the solution was to move libsasl.dll to the same
location as php_ldap.dll. I also found documentation stating that
libsasl.dll was already bundled into 4.3.0. I was unable to locate
libsasl.dll anywhere in the binary zip of 4.3.0.
I've noticed at least two other people here experiencing similiar
problems.
------------------------------------------------------------------------
--
Edit this bug report at http://bugs.php.net/?id=21522&edit=1