#21522 [Com]: Ldap unable to load - module not found
| From: | dralibak at yahoo dot com | Date: | Fri, 10 Sep 2004 05:58:15 +0000 |
| Subject: | #21522 [Com]: Ldap unable to load - module not found | ||
| References: | 1 | Groups: | php.bugs |
| Request: | Send a blank email to php-bugs+get-65978@lists.php.net to get a copy of this message | ||
ID: 21522
Comment by: dralibak at yahoo dot com
Reported By: bool at gte dot net
Status: Bogus
Bug Type: LDAP related
Operating System: Windots NT
PHP Version: 4.3.0
New Comment:
Hi, I have all the extensions downloaded from the 5.01 version of php
and pecl. I keep getting the "unable to load" and the "()" ! same
issues as above. I've read the install.txt with regard to the
extensions. It's not recognizing the php_mysql.dll during the start.
the older 4.3 cgi version with installer worked fine but.. not the
5.01 (used installer). in the php.ini, it says something about
enabling the dll function doesn't work in the windows nt or 2003?..
ok any suggestions?
Previous Comments:
------------------------------------------------------------------------
[2003-01-09 08:53:19] bool at gte dot net
I fell like a dolt now... I copied the files and everything is working
like a charm. Thank you very much for the help.
------------------------------------------------------------------------
[2003-01-08 17:51:14] edink@php.net
You probably missed a part in the install intructions about copying
dlls\*.dll to c:\winnt\system32.
------------------------------------------------------------------------
[2003-01-08 12:46:16] bool at gte dot net
When attempting to enable the extension php_ldap.dll from the 4.3.0
windows binary build I first copied the dll to c:\php\, set the proper
variable in php.ini to tell php to look for extensions in c:\php and
uncommented the line extension=php_ldap.dll. save, shutdown iis,
restart to get an error telling me that module c:\php\php_ldap.dll is
not found and there is a refrence to function Unknown().
After verifying that I did not screw up my copy job and the file
c:\php\php_ldap.dll DID exist I came back to the site and did a serch
for others having the same problem. In 2001 there were many refrences
to the same error and the solution was to move libsasl.dll to the same
location as php_ldap.dll. I also found documentation stating that
libsasl.dll was already bundled into 4.3.0. I was unable to locate
libsasl.dll anywhere in the binary zip of 4.3.0.
I've noticed at least two other people here experiencing similiar
problems.
------------------------------------------------------------------------
--
Edit this bug report at http://bugs.php.net/?id=21522&edit=1