#29835 [NEW]: OCI8 module could not load in IIS
| From: | izhekov at ppartner dot com | Date: | Wed, 25 Aug 2004 13:35:27 +0000 |
| Subject: | #29835 [NEW]: OCI8 module could not load in IIS | ||
| Groups: | php.bugs | ||
| Request: | Send a blank email to php-bugs+get-65230@lists.php.net to get a copy of this message | ||
From: izhekov at ppartner dot com
Operating system: Windows 2003
PHP version: 5.0.1
PHP Bug Type: OCI8 related
Bug description: OCI8 module could not load in IIS
Description:
------------
I've tried to install PHP on IIS 6 with Oracle module support.
Everything is set correctly - the PHP installation instructions are
executed, an Oracle client is installed, Oracle environments are set.
The problem is that when I try to open any .php script, the web server
return an error message:
"Unable to load dynamic library c:\php\ext\php_oci8.dll: Access denied"
The file php_oci8.dll is right there and it have property permissions set.
oci.dll is located in %ORACLE_HOME%\bin\. I've tried this on three
different servers and the problem is on all of them. Oracle version is
9.2.0.1.0.
--
Edit bug report at http://bugs.php.net/?id=29835&edit=1
--
Try a CVS snapshot (php4): http://bugs.php.net/fix.php?id=29835&r=trysnapshot4
Try a CVS snapshot (php5.0): http://bugs.php.net/fix.php?id=29835&r=trysnapshot50
Try a CVS snapshot (php5.1): http://bugs.php.net/fix.php?id=29835&r=trysnapshot51
Fixed in CVS: http://bugs.php.net/fix.php?id=29835&r=fixedcvs
Fixed in release: http://bugs.php.net/fix.php?id=29835&r=alreadyfixed
Need backtrace: http://bugs.php.net/fix.php?id=29835&r=needtrace
Need Reproduce Script: http://bugs.php.net/fix.php?id=29835&r=needscript
Try newer version: http://bugs.php.net/fix.php?id=29835&r=oldversion
Not developer issue: http://bugs.php.net/fix.php?id=29835&r=support
Expected behavior: http://bugs.php.net/fix.php?id=29835&r=notwrong
Not enough info: http://bugs.php.net/fix.php?id=29835&r=notenoughinfo
Submitted twice: http://bugs.php.net/fix.php?id=29835&r=submittedtwice
register_globals: http://bugs.php.net/fix.php?id=29835&r=globals
PHP 3 support discontinued: http://bugs.php.net/fix.php?id=29835&r=php3
Daylight Savings: http://bugs.php.net/fix.php?id=29835&r=dst
IIS Stability: http://bugs.php.net/fix.php?id=29835&r=isapi
Install GNU Sed: http://bugs.php.net/fix.php?id=29835&r=gnused
Floating point limitations: http://bugs.php.net/fix.php?id=29835&r=float