#30465 [NEW]: Apache fails to load GD DLL but cli ok...
| From: | derek at netsimple dot net | Date: | Sun, 17 Oct 2004 19:05:48 +0000 |
| Subject: | #30465 [NEW]: Apache fails to load GD DLL but cli ok... | ||
| Groups: | php.bugs | ||
| Request: | Send a blank email to php-bugs+get-67692@lists.php.net to get a copy of this message | ||
From: derek at netsimple dot net
Operating system: WinXP Pro
PHP version: 4.3.9
PHP Bug Type: Apache2 related
Bug description: Apache fails to load GD DLL but cli ok...
Description:
------------
Installation notes:
- OS: WinXP Pro
- PHP: 4.3.9 (and also 4.3.1)
Installed via zip and windows installer (same result)
- Webserver: Apache 2.0.52
The module (php_gd2.dll) I tried seems to load OK from the command line,
but not from within Apache.
I have read all the installation documentation, and also grepped yahoo and
google for an answer. Nearly all the solutions mention the editing
"extension_dir" in the php.ini file. I believe my config is appropriate to
my installation...?
The practice of copying dlls to the %SYSTEM% directory seems to have
worked for some, but not for me. Anyway, this is not mentioned *anywhere*
in the installation notes, so I don't think it's appropriate.
Other things I have tried:
- comment out the extension_dir directive completely
I get a similar error but refers to C:\php4\... even after copying all the
available dlls to that location.
Reproduce code:
---------------
Extract from configuration files:
c:\program files\apache\apache2\conf\httpd.conf...
<------------------------------->
# PHP
LoadModule php4_module "c:/php/4.3.9/sapi/php4apache2.dll"
PHPIniDir "C:/php/4.3.9"
SetEnv PHPRC C:/php/4.3.9
AddType application/x-httpd-php .php
<------------------------------->
c:\php\4.3.9\php.ini
<------------------------------->
extension_dir = "C:\PHP\4.3.9\extensions"
...
extension=php_gd2.dll
<------------------------------->
Expected result:
----------------
GD should be found in the extensions directory (where the dll is located)
for:
- CLI
- Apache2
Actual result:
--------------
From the command line:
----------------------
c:\PHP\4.3.9\php.exe -m
[PHP Modules]
bcmath
calendar
com
ctype
ftp
gd <--------------- here it is!
mysql
odbc
overload
pcre
session
standard
tokenizer
wddx
xml
zlib
[Zend Modules]
When starting Apache2:
----------------------
On starting Apache2, I get the following message:
Unknown(): Unable to load dynamic library
'c:\PHP\4.3.9\extensions\php_dg2.dll'
--
Edit bug report at http://bugs.php.net/?id=30465&edit=1
--
Try a CVS snapshot (php4): http://bugs.php.net/fix.php?id=30465&r=trysnapshot4
Try a CVS snapshot (php5.0): http://bugs.php.net/fix.php?id=30465&r=trysnapshot50
Try a CVS snapshot (php5.1): http://bugs.php.net/fix.php?id=30465&r=trysnapshot51
Fixed in CVS: http://bugs.php.net/fix.php?id=30465&r=fixedcvs
Fixed in release: http://bugs.php.net/fix.php?id=30465&r=alreadyfixed
Need backtrace: http://bugs.php.net/fix.php?id=30465&r=needtrace
Need Reproduce Script: http://bugs.php.net/fix.php?id=30465&r=needscript
Try newer version: http://bugs.php.net/fix.php?id=30465&r=oldversion
Not developer issue: http://bugs.php.net/fix.php?id=30465&r=support
Expected behavior: http://bugs.php.net/fix.php?id=30465&r=notwrong
Not enough info: http://bugs.php.net/fix.php?id=30465&r=notenoughinfo
Submitted twice: http://bugs.php.net/fix.php?id=30465&r=submittedtwice
register_globals: http://bugs.php.net/fix.php?id=30465&r=globals
PHP 3 support discontinued: http://bugs.php.net/fix.php?id=30465&r=php3
Daylight Savings: http://bugs.php.net/fix.php?id=30465&r=dst
IIS Stability: http://bugs.php.net/fix.php?id=30465&r=isapi
Install GNU Sed: http://bugs.php.net/fix.php?id=30465&r=gnused
Floating point limitations: http://bugs.php.net/fix.php?id=30465&r=float
MySQL Configuration Error: http://bugs.php.net/fix.php?id=30465&r=mysqlcfg