#30465 [Opn->Csd]: Apache fails to load GD DLL but cli ok...
| From: | derek at netsimple dot net | Date: | Sun, 17 Oct 2004 19:48:08 +0000 |
| Subject: | #30465 [Opn->Csd]: Apache fails to load GD DLL but cli ok... | ||
| References: | 1 | Groups: | php.bugs |
| Request: | Send a blank email to php-bugs+get-67695@lists.php.net to get a copy of this message | ||
ID: 30465
User updated by: derek at netsimple dot net
Reported By: derek at netsimple dot net
-Status: Open
+Status: Closed
-Bug Type: Apache2 related
+Bug Type: Dynamic loading
Operating System: WinXP Pro
PHP Version: 4.3.9
New Comment:
I've amended this to Dynamic loading, but it could just as easily have
been 'Installation' (if there was such a section.
Anyway, trying the cli/php.exe program produce an "point_safe_emalloc"
error pointing to the php4ts.dll file. I copied the
php/4.3.9/php4ts.dll to %WINDOWS%\system32 and was surprised to find a
version already there from March 2004...
Killing Apache2, making the copy and starting Apache2 seemed to fix the
problem.
Points to note:
- PHP don't function without this file in the system32 dir.
- The installation left the old version of the file in tact.
Rgds,
Derek
Previous Comments:
------------------------------------------------------------------------
[2004-10-17 21:30:49] derek at netsimple dot net
Hi Derick,
Thanks for the quick response.
I only have one php.ini file in the C:\PHP\4.3.9 directory and one in
C:\PHP\4.3.9 - searched whe whole c: drive for them. The installation
actually put the php.ini file in %WINDOWS% directory, but I moved it
back to the 4.3.9 directory.
According to the apache httpd.conf file it should be looking at the
C:\PHP\4.3.9 directory anyway - that's where the config says to look.
If I follow the installation instructions to the letter, and the
installation doesn't work (ALL the dynamic dlls have this error),
there's a bug. It's that simple, no?
------------------------------------------------------------------------
[2004-10-17 21:17:48] derick@php.net
Sorry, but your problem does not imply a bug in PHP itself. For a
list of more appropriate places to ask for help using PHP, please
visit http://www.php.net/support.php as this bug system
is not the
appropriate forum for asking support questions.
Thank you for your interest in PHP.
php_dg2.dll it says, i think you have two different php.ini files and
did something wrong in one.
------------------------------------------------------------------------
[2004-10-17 21:05:32] derek at netsimple dot net
Description:
------------
Installation notes:
- OS: WinXP Pro
- PHP: 4.3.9 (and also 4.3.1)
Installed via zip and windows installer (same result)
- Webserver: Apache 2.0.52
The module (php_gd2.dll) I tried seems to load OK from the command
line, but not from within Apache.
I have read all the installation documentation, and also grepped yahoo
and google for an answer. Nearly all the solutions mention the editing
"extension_dir" in the php.ini file. I believe my config is appropriate
to my installation...?
The practice of copying dlls to the %SYSTEM% directory seems to have
worked for some, but not for me. Anyway, this is not mentioned
*anywhere* in the installation notes, so I don't think it's
appropriate.
Other things I have tried:
- comment out the extension_dir directive completely
I get a similar error but refers to C:\php4\... even after copying all
the available dlls to that location.
Reproduce code:
---------------
Extract from configuration files:
c:\program files\apache\apache2\conf\httpd.conf...
<------------------------------->
# PHP
LoadModule php4_module "c:/php/4.3.9/sapi/php4apache2.dll"
PHPIniDir "C:/php/4.3.9"
SetEnv PHPRC C:/php/4.3.9
AddType application/x-httpd-php .php
<------------------------------->
c:\php\4.3.9\php.ini
<------------------------------->
extension_dir = "C:\PHP\4.3.9\extensions"
...
extension=php_gd2.dll
<------------------------------->
Expected result:
----------------
GD should be found in the extensions directory (where the dll is
located) for:
- CLI
- Apache2
Actual result:
--------------
From the command line:
----------------------
c:\PHP\4.3.9\php.exe -m
[PHP Modules]
bcmath
calendar
com
ctype
ftp
gd <--------------- here it is!
mysql
odbc
overload
pcre
session
standard
tokenizer
wddx
xml
zlib
[Zend Modules]
When starting Apache2:
----------------------
On starting Apache2, I get the following message:
Unknown(): Unable to load dynamic library
'c:\PHP\4.3.9\extensions\php_dg2.dll'
------------------------------------------------------------------------
--
Edit this bug report at http://bugs.php.net/?id=30465&edit=1