#30952 [NEW]: libpng.so.3 error after compiling php5.0.3rc1 with gd
| From: | iansutherland75 at gmail dot com | Date: | Wed, 01 Dec 2004 19:44:37 +0000 |
| Subject: | #30952 [NEW]: libpng.so.3 error after compiling php5.0.3rc1 with gd | ||
| Groups: | php.bugs | ||
| Request: | Send a blank email to php-bugs+get-69697@lists.php.net to get a copy of this message | ||
From: iansutherland75 at gmail dot com
Operating system: Fedora Core 3
PHP version: 5.0.2
PHP Bug Type: GD related
Bug description: libpng.so.3 error after compiling php5.0.3rc1 with gd
Description:
------------
I get this error message whenever I try to start apache now that I've
compiled PHP5.0.3rc1 with GD.
quote:
--------------------------------------------------------------------------------
Failed to start apache :
Starting httpd: Syntax error on line 190 of /etc/httpd/conf/httpd.conf:
Cannot load /usr/lib/httpd/modules/libphp5.so into server: libpng.so.3:
failed to map segment from shared object: Permission denied
[FAILED]
--------------------------------------------------------------------------------
My server is Fedora core 3, and I've got libgd, libgd-devel, libgd-progs,
libpng, libpng-devel, libjpeg, and libjpeg-devel all installed.
I've confirmed that libpng.so.3 is in my /usr/lib/ folder and I even
chmod'd it to 777 to make sure I had ok permissions.
--
Edit bug report at http://bugs.php.net/?id=30952&edit=1
--
Try a CVS snapshot (php4): http://bugs.php.net/fix.php?id=30952&r=trysnapshot4
Try a CVS snapshot (php5.0): http://bugs.php.net/fix.php?id=30952&r=trysnapshot50
Try a CVS snapshot (php5.1): http://bugs.php.net/fix.php?id=30952&r=trysnapshot51
Fixed in CVS: http://bugs.php.net/fix.php?id=30952&r=fixedcvs
Fixed in release: http://bugs.php.net/fix.php?id=30952&r=alreadyfixed
Need backtrace: http://bugs.php.net/fix.php?id=30952&r=needtrace
Need Reproduce Script: http://bugs.php.net/fix.php?id=30952&r=needscript
Try newer version: http://bugs.php.net/fix.php?id=30952&r=oldversion
Not developer issue: http://bugs.php.net/fix.php?id=30952&r=support
Expected behavior: http://bugs.php.net/fix.php?id=30952&r=notwrong
Not enough info: http://bugs.php.net/fix.php?id=30952&r=notenoughinfo
Submitted twice: http://bugs.php.net/fix.php?id=30952&r=submittedtwice
register_globals: http://bugs.php.net/fix.php?id=30952&r=globals
PHP 3 support discontinued: http://bugs.php.net/fix.php?id=30952&r=php3
Daylight Savings: http://bugs.php.net/fix.php?id=30952&r=dst
IIS Stability: http://bugs.php.net/fix.php?id=30952&r=isapi
Install GNU Sed: http://bugs.php.net/fix.php?id=30952&r=gnused
Floating point limitations: http://bugs.php.net/fix.php?id=30952&r=float
MySQL Configuration Error: http://bugs.php.net/fix.php?id=30952&r=mysqlcfg