#30952 [Opn->Bgs]: libpng.so.3 error after compiling php5.0.3rc1 with gd
| From: | jorton@php.net | Date: | Fri, 03 Dec 2004 07:57:51 +0000 |
| Subject: | #30952 [Opn->Bgs]: libpng.so.3 error after compiling php5.0.3rc1 with gd | ||
| References: | 1 | Groups: | php.bugs |
| Request: | Send a blank email to php-bugs+get-69758@lists.php.net to get a copy of this message | ||
ID: 30952
Updated by: jorton@php.net
Reported By: iansutherland75 at gmail dot com
-Status: Open
+Status: Bogus
Bug Type: GD related
Operating System: Fedora Core 3
PHP Version: 5.0.2
New Comment:
That's an SELinux labelling issue - run:
# fixfiles restore
or disable enforcement of the Apache/SELinux policy:
# setsebool httpd_disable_trans 1
Previous Comments:
------------------------------------------------------------------------
[2004-12-01 20:44:34] iansutherland75 at gmail dot com
Description:
------------
I get this error message whenever I try to start apache now that I've
compiled PHP5.0.3rc1 with GD.
quote:
--------------------------------------------------------------------------------
Failed to start apache :
Starting httpd: Syntax error on line 190 of /etc/httpd/conf/httpd.conf:
Cannot load /usr/lib/httpd/modules/libphp5.so into server: libpng.so.3:
failed to map segment from shared object: Permission denied
[FAILED]
--------------------------------------------------------------------------------
My server is Fedora core 3, and I've got libgd, libgd-devel,
libgd-progs, libpng, libpng-devel, libjpeg, and libjpeg-devel all
installed.
I've confirmed that libpng.so.3 is in my /usr/lib/ folder and I even
chmod'd it to 777 to make sure I had ok permissions.
------------------------------------------------------------------------
--
Edit this bug report at http://bugs.php.net/?id=30952&edit=1