Bug #17042: Problem with running php under apache control

From: Date: Mon, 06 May 2002 13:02:45 +0000
Subject: Bug #17042: Problem with running php under apache control
Groups: php.bugs 
Request: Send a blank email to php-bugs+get-7033@lists.php.net to get a copy of this message
From: yeyo@wp.pl Operating system: Free BSD 4.5 RELEASE PHP version: 4.2.0 PHP Bug Type: Apache2 related Bug description: Problem with running php under apache control I've previous compiled Apache ver. 2.0.35 PHP ver 4.2.0: ./configure --witch-mysql --witch-apxs=/path/to/apxs make make install I've added to httpd.conf this line: "LoadModule php4_module modules/libphp4.so" During I was starting http's daemon (with ./apachectl startssl or ./httpd) it crashes with message: Syntax error on line 217 of /usr/apache/conf/httpd.conf: Cannot load /usr/apache/modules/libphp4.so into server: /usr/apache/modules/libphp4.so: Undefined symbol "pthread_getspecific" ./apachectl startssl: httpd could not be started What's going on ? -- Edit bug report at http://bugs.php.net/?id=17042&edit=1 -- Fixed in CVS: http://bugs.php.net/fix.php?id=17042&r=fixedcvs Fixed in release: http://bugs.php.net/fix.php?id=17042&r=alreadyfixed Need backtrace: http://bugs.php.net/fix.php?id=17042&r=needtrace Try newer version: http://bugs.php.net/fix.php?id=17042&r=oldversion Not developer issue: http://bugs.php.net/fix.php?id=17042&r=support Expected behavior: http://bugs.php.net/fix.php?id=17042&r=notwrong Not enough info: http://bugs.php.net/fix.php?id=17042&r=notenoughinfo Submitted twice: http://bugs.php.net/fix.php?id=17042&r=submittedtwice register_globals: http://bugs.php.net/fix.php?id=17042&r=globals

« previous php.bugs (#7033) next »