#31505 [NEW]: php5apache2.dll probably is causing Apache to fail

From: Date: Wed, 12 Jan 2005 03:07:51 +0000
Subject: #31505 [NEW]: php5apache2.dll probably is causing Apache to fail
Groups: php.bugs 
Request: Send a blank email to php-bugs+get-71906@lists.php.net to get a copy of this message
From: listen at hotpop dot com Operating system: W2Kpro sp4 PHP version: 5.0.3 PHP Bug Type: Apache2 related Bug description: php5apache2.dll probably is causing Apache to fail Description: ------------ I'm using the latest stable Apache2 Windows binary installed by: apache_2.0.52-win32-x86-no_ssl.msi together with PHP 5.0.3 and MySQL 4.0.21-nt and phpMyAdmin 2.6.0-pl1. Up until now I ran PHP in the cgi mode, but a few days ago I changed over to run it as an Apache module in order to be able to do httpd-www authentication. Apparently everything was working fine, both in the cgi mode as well as when it was run as an Apache module using php5apache2.dll. On tuesday 11/01-2005 I then tried to install the wordpress blog application, only to learn that it locked up during phase 2 of the installation. The Apache server returned a message like: Apache.exe - Program failure. instruction at 0x005b589c referenced memory at 0x00000003 the memory couldn't be read. When I then used the phpMyAdmin in order to inspect the contents of the created tables, the phpMyAdmin simply locked up, and wasn't able to display anything. Again the error message was produced by the Apache server. Next I tried a reboot and found that after the reboot the errorcondition was still produced as described above. Next I tried to go back to cgi mode, where I found that the errorcondition didn't occur. From these findings I believe the problem is caused by the php5apache2.dll, and unfortunately I need to run php as an Apache module, because I need the httpd-www authenticate functionality. Best regards, Arne Eckmann -- Edit bug report at http://bugs.php.net/?id=31505&edit=1 -- Try a CVS snapshot (php4): http://bugs.php.net/fix.php?id=31505&r=trysnapshot4 Try a CVS snapshot (php5.0): http://bugs.php.net/fix.php?id=31505&r=trysnapshot50 Try a CVS snapshot (php5.1): http://bugs.php.net/fix.php?id=31505&r=trysnapshot51 Fixed in CVS: http://bugs.php.net/fix.php?id=31505&r=fixedcvs Fixed in release: http://bugs.php.net/fix.php?id=31505&r=alreadyfixed Need backtrace: http://bugs.php.net/fix.php?id=31505&r=needtrace Need Reproduce Script: http://bugs.php.net/fix.php?id=31505&r=needscript Try newer version: http://bugs.php.net/fix.php?id=31505&r=oldversion Not developer issue: http://bugs.php.net/fix.php?id=31505&r=support Expected behavior: http://bugs.php.net/fix.php?id=31505&r=notwrong Not enough info: http://bugs.php.net/fix.php?id=31505&r=notenoughinfo Submitted twice: http://bugs.php.net/fix.php?id=31505&r=submittedtwice register_globals: http://bugs.php.net/fix.php?id=31505&r=globals PHP 3 support discontinued: http://bugs.php.net/fix.php?id=31505&r=php3 Daylight Savings: http://bugs.php.net/fix.php?id=31505&r=dst IIS Stability: http://bugs.php.net/fix.php?id=31505&r=isapi Install GNU Sed: http://bugs.php.net/fix.php?id=31505&r=gnused Floating point limitations: http://bugs.php.net/fix.php?id=31505&r=float No Zend Extensions: http://bugs.php.net/fix.php?id=31505&r=nozend MySQL Configuration Error: http://bugs.php.net/fix.php?id=31505&r=mysqlcfg

« previous php.bugs (#71906) next »