#31505 [Bgs]: php5apache2.dll probably is causing Apache to fail

From: Date: Wed, 12 Jan 2005 23:51:54 +0000
Subject: #31505 [Bgs]: php5apache2.dll probably is causing Apache to fail
References: 1  Groups: php.bugs 
Request: Send a blank email to php-bugs+get-72012@lists.php.net to get a copy of this message
 ID:               31505
 User updated by:  listen at hotpop dot com
 Reported By:      listen at hotpop dot com
 Status:           Bogus
 Bug Type:         Apache2 related
 Operating System: W2Kpro sp4
 PHP Version:      5.0.3
 New Comment:

Your reaction is highly inappropriate. Obviously error reports on php
are not welcome - end of story, and no reason to be rude.


Previous Comments:
------------------------------------------------------------------------

[2005-01-12 05:28:38] jed@php.net

Sorry, but your problem does not imply a bug in PHP itself.  For a
list of more appropriate places to ask for help using PHP, please
visit http://www.php.net/support.php as this bug system
is not the
appropriate forum for asking support questions. 

Thank you for your interest in PHP.

Works fine here on my 2K box, as well as my XP box. There's a lot of
variables in your bug report that don't necessarily point to PHP.

------------------------------------------------------------------------

[2005-01-12 04:07:50] listen at hotpop dot com

Description:
------------
I'm using the latest stable Apache2 Windows binary installed by:
apache_2.0.52-win32-x86-no_ssl.msi together with PHP 5.0.3 and MySQL
4.0.21-nt and phpMyAdmin 2.6.0-pl1.

Up until now I ran PHP in the cgi mode, but a few days ago I changed
over to run it as an Apache module in order to be able to do httpd-www
authentication.

Apparently everything was working fine, both in the cgi mode as well as
when it was run as an Apache module using php5apache2.dll.

On tuesday 11/01-2005 I then tried to install the wordpress blog
application, only to learn that it locked up during phase 2 of the
installation.

The Apache server returned a message like:

Apache.exe - Program failure.
instruction at 0x005b589c referenced memory at 0x00000003
the memory couldn't be read.

When I then used the phpMyAdmin in order to inspect the contents of the
created tables, the phpMyAdmin simply locked up, and wasn't able to
display anything.

Again the error message was produced by the Apache server.

Next I tried a reboot and found that after the reboot the
errorcondition was still produced as described above.

Next I tried to go back to cgi mode, where I found that the
errorcondition didn't occur.

From these findings I believe the problem is caused by the 
php5apache2.dll, and unfortunately I need to run php as an Apache
module, because I need the httpd-www authenticate functionality.

Best regards,

Arne Eckmann
 
 
  



------------------------------------------------------------------------


-- 
Edit this bug report at http://bugs.php.net/?id=31505&edit=1


Thread (11 messages)

« previous php.bugs (#72012) next »