Bug #17005 Updated: Configure failure using apxs2
| From: | sunkan at zappa dot cx | Date: | Wed, 15 May 2002 11:27:49 +0000 |
| Subject: | Bug #17005 Updated: Configure failure using apxs2 | ||
| References: | 1 | Groups: | php.bugs |
| Request: | Send a blank email to php-bugs+get-7737@lists.php.net to get a copy of this message | ||
ID: 17005
Updated by: sunkan@zappa.cx
Reported By: aaabbb@alb.org.uk
Status: Open
Bug Type: Apache2 related
Operating System: RedHat 7.2
PHP Version: 4.0CVS-2002-05-04
New Comment:
I think this might be the cause of a bug in the apxs script. It fails
when sbindir != bindir
Have a look at my report in apaches bug db:
http://nagoya.apache.org/bugzilla/show_bug.cgi?id=8869
The fix will be included in apache 2.0.37, if you want to try it
already there's a patch in the report above.
Previous Comments:
------------------------------------------------------------------------
[2002-05-04 14:02:02] aaabbb@alb.org.uk
I have tried running the configure script on both the current download
version of php4 and also the latest CVS version.
The compile script stops when it checks for apxs.
I used the following command on both occations:
./configure --with-mysql --with-apxs2=/usr/sbin/apxs
I have re-compiled apache-2.0.35 several times in the belief that there
was a problem with the installation.
The configure command used for apache is:
./configure --enable-layout=RedHat --enable-ssl=shared
--enable-disk-cache --enable-mem-cache --enable-mods-shared=all
Apache compiles successfuly and works as expected.
The end of the php4 configure script follows:
...
Configuring SAPI modules
checking for AOLserver support... no
checking for Apache 1.x module support via DSO through APXS... no
checking for Apache 1.x module support... no
checking for mod_charset compatibility option... no
checking for Apache 2.0 module support via DSO through APXS...
Sorry, I cannot run apxs. Possible reasons follow:
1. Perl is not installed
2. apxs was not found. Try to pass the path using
--with-apxs2=/path/to/apxs
3. Apache was not built using --enable-so (the apxs usage page is
displayed)
The output of /usr/sbin/apxs follows:
Usage: apxs -g [-S <var>=<val>] -n <modname>
apxs -q [-S <var>=<val>] <query> ...
apxs -c [-S <var>=<val>] [-o <dsofile>] [-D <name>[=<value>]]
[-I <incdir>] [-L <libdir>] [-l <libname>]
[-Wc,<flags>]
[-Wl,<flags>] <files> ...
apxs -i [-S <var>=<val>] [-a] [-A] [-n <modname>] <dsofile> ...
apxs -e [-S <var>=<val>] [-a] [-A] [-n <modname>] <dsofile> ...
configure: error: Aborting
Thanks in advance.
Yours,
Andy B
------------------------------------------------------------------------
--
Edit this bug report at http://bugs.php.net/?id=17005&edit=1