Bug #17005 Updated: Configure failure using apxs2
| From: | jwoolley@php.net | Date: | Fri, 17 May 2002 07:38:48 +0000 |
| Subject: | Bug #17005 Updated: Configure failure using apxs2 | ||
| References: | 1 | Groups: | php.bugs |
| Request: | Send a blank email to php-bugs+get-7903@lists.php.net to get a copy of this message | ||
ID: 17005
Updated by: jwoolley@php.net
Reported By: aaabbb@alb.org.uk
-Status: Open
+Status: Closed
Bug Type: Apache2 related
Operating System: RedHat 7.2
PHP Version: 4.0CVS-2002-05-04
New Comment:
This bug has been fixed in CVS. You can grab a snapshot of the
CVS version at http://snaps.php.net/. In case this was a
documentation
problem, the fix will show up soon at http://www.php.net/manual/.
In case this was a PHP.net website problem, the change will show
up on the PHP.net site and on the mirror sites.
Thank you for the report, and for helping us make PHP better.
I'm going to assume the apxs bug that was mentioned in this report
really was the problem and close this out. If you find that it still
doesn't work with Apache 2.0.37, please feel free to open a new report.
Thanks!
Previous Comments:
------------------------------------------------------------------------
[2002-05-15 07:27:49] sunkan@zappa.cx
I think this might be the cause of a bug in the apxs script. It fails
when sbindir != bindir
Have a look at my report in apaches bug db:
http://nagoya.apache.org/bugzilla/show_bug.cgi?id=8869
The fix will be included in apache 2.0.37, if you want to try it
already there's a patch in the report above.
------------------------------------------------------------------------
[2002-05-04 14:02:02] aaabbb@alb.org.uk
I have tried running the configure script on both the current download
version of php4 and also the latest CVS version.
The compile script stops when it checks for apxs.
I used the following command on both occations:
./configure --with-mysql --with-apxs2=/usr/sbin/apxs
I have re-compiled apache-2.0.35 several times in the belief that there
was a problem with the installation.
The configure command used for apache is:
./configure --enable-layout=RedHat --enable-ssl=shared
--enable-disk-cache --enable-mem-cache --enable-mods-shared=all
Apache compiles successfuly and works as expected.
The end of the php4 configure script follows:
...
Configuring SAPI modules
checking for AOLserver support... no
checking for Apache 1.x module support via DSO through APXS... no
checking for Apache 1.x module support... no
checking for mod_charset compatibility option... no
checking for Apache 2.0 module support via DSO through APXS...
Sorry, I cannot run apxs. Possible reasons follow:
1. Perl is not installed
2. apxs was not found. Try to pass the path using
--with-apxs2=/path/to/apxs
3. Apache was not built using --enable-so (the apxs usage page is
displayed)
The output of /usr/sbin/apxs follows:
Usage: apxs -g [-S <var>=<val>] -n <modname>
apxs -q [-S <var>=<val>] <query> ...
apxs -c [-S <var>=<val>] [-o <dsofile>] [-D <name>[=<value>]]
[-I <incdir>] [-L <libdir>] [-l <libname>]
[-Wc,<flags>]
[-Wl,<flags>] <files> ...
apxs -i [-S <var>=<val>] [-a] [-A] [-n <modname>] <dsofile> ...
apxs -e [-S <var>=<val>] [-a] [-A] [-n <modname>] <dsofile> ...
configure: error: Aborting
Thanks in advance.
Yours,
Andy B
------------------------------------------------------------------------
--
Edit this bug report at http://bugs.php.net/?id=17005&edit=1