#33004 [NEW]: undefined symbol: sapi_module
| From: | fontana at netw dot it | Date: | Tue, 10 May 2005 21:54:53 +0000 |
| Subject: | #33004 [NEW]: undefined symbol: sapi_module | ||
| Groups: | php.bugs | ||
| Request: | Send a blank email to php-bugs+get-78869@lists.php.net to get a copy of this message | ||
From: fontana at netw dot it
Operating system: linux
PHP version: 5.0.4
PHP Bug Type: Apache2 related
Bug description: undefined symbol: sapi_module
Description:
------------
Hello,
The system where I tried to run php 5.0.4 is configured as
follow:
1. gcc 3.4.3
2. apache 2.0.54 compiled by myself (./configure
--enable-so is the configure command I used the last time)
3. php 5.0.4 compiledby myself (./configure
--with-apxs2=/usr/local/apache2/bin/apxs is the configure
command)
After the installation of both apache and php I'm
receiving the following error:
Syntax error on line 232
of /usr/local/apache2/conf/httpd.conf:
Cannot load /usr/local/apache2/modules/libphp5.so into
server: /usr/local/apache2/modules/libphp5.so: undefined
symbol: sapi_module
The line number 232 is:
LoadModule php5_module modules/libphp5.so
This is the first time since I use/compile php/apache that
I receive this error. I tried with different configure
parameters but I always receive the error above.
regards
Christian
--
Edit bug report at http://bugs.php.net/?id=33004&edit=1
--
Try a CVS snapshot (php4): http://bugs.php.net/fix.php?id=33004&r=trysnapshot4
Try a CVS snapshot (php5.0): http://bugs.php.net/fix.php?id=33004&r=trysnapshot50
Try a CVS snapshot (php5.1): http://bugs.php.net/fix.php?id=33004&r=trysnapshot51
Fixed in CVS: http://bugs.php.net/fix.php?id=33004&r=fixedcvs
Fixed in release: http://bugs.php.net/fix.php?id=33004&r=alreadyfixed
Need backtrace: http://bugs.php.net/fix.php?id=33004&r=needtrace
Need Reproduce Script: http://bugs.php.net/fix.php?id=33004&r=needscript
Try newer version: http://bugs.php.net/fix.php?id=33004&r=oldversion
Not developer issue: http://bugs.php.net/fix.php?id=33004&r=support
Expected behavior: http://bugs.php.net/fix.php?id=33004&r=notwrong
Not enough info: http://bugs.php.net/fix.php?id=33004&r=notenoughinfo
Submitted twice: http://bugs.php.net/fix.php?id=33004&r=submittedtwice
register_globals: http://bugs.php.net/fix.php?id=33004&r=globals
PHP 3 support discontinued: http://bugs.php.net/fix.php?id=33004&r=php3
Daylight Savings: http://bugs.php.net/fix.php?id=33004&r=dst
IIS Stability: http://bugs.php.net/fix.php?id=33004&r=isapi
Install GNU Sed: http://bugs.php.net/fix.php?id=33004&r=gnused
Floating point limitations: http://bugs.php.net/fix.php?id=33004&r=float
No Zend Extensions: http://bugs.php.net/fix.php?id=33004&r=nozend
MySQL Configuration Error: http://bugs.php.net/fix.php?id=33004&r=mysqlcfg