#33004 [Bgs]: undefined symbol: sapi_module

From: Date: Thu, 12 May 2005 13:21:36 +0000
Subject: #33004 [Bgs]: undefined symbol: sapi_module
References: 1  Groups: php.bugs 
Request: Send a blank email to php-bugs+get-78936@lists.php.net to get a copy of this message
ID: 33004 User updated by: fontana at netw dot it Reported By: fontana at netw dot it Status: Bogus Bug Type: Apache2 related Operating System: linux PHP Version: 5.0.4 New Comment: The problem was due (probably) to different compilation made in sequence. I deleted the php source tree, then I untared the package, I recompiled with the parameters used before. I suppose that there is a bug in the make clean "script section". The linux version I use is one derived from LFS with only the libraries/packages... needed for the pourpose of the server. Thanks Christian Previous Comments: ------------------------------------------------------------------------ [2005-05-11 01:34:14] sniper@php.net There is something wrong with your system for this to happen. Nobody else has reported anything like this before and I sure can not reproduce this either. If you can prove that this happens on some other machine, reopen, otherwise consider reinstalling the one you're trying with now. (might even be a hardware issue, like faulty memory..) Best choice: Use binary packages (RPMs, etc.) (you failed to give the actual OS) ------------------------------------------------------------------------ [2005-05-11 00:31:16] fontana at netw dot it I have just tried with the same apache installation but with php 5.0.1 (with the same configure command) and everything works fine Regards Christian ------------------------------------------------------------------------ [2005-05-10 23:54:52] fontana at netw dot it Description: ------------ Hello, The system where I tried to run php 5.0.4 is configured as follow: 1. gcc 3.4.3 2. apache 2.0.54 compiled by myself (./configure --enable-so is the configure command I used the last time) 3. php 5.0.4 compiledby myself (./configure --with-apxs2=/usr/local/apache2/bin/apxs is the configure command) After the installation of both apache and php I'm receiving the following error: Syntax error on line 232 of /usr/local/apache2/conf/httpd.conf: Cannot load /usr/local/apache2/modules/libphp5.so into server: /usr/local/apache2/modules/libphp5.so: undefined symbol: sapi_module The line number 232 is: LoadModule php5_module modules/libphp5.so This is the first time since I use/compile php/apache that I receive this error. I tried with different configure parameters but I always receive the error above. regards Christian ------------------------------------------------------------------------ -- Edit this bug report at http://bugs.php.net/?id=33004&edit=1

« previous php.bugs (#78936) next »