#33292 [Opn->Fbk]: apache_get_modules crashes
| From: | sniper@php.net | Date: | Sat, 11 Jun 2005 17:47:09 +0000 |
| Subject: | #33292 [Opn->Fbk]: apache_get_modules crashes | ||
| References: | 1 | Groups: | php.bugs |
| Request: | Send a blank email to php-bugs+get-80171@lists.php.net to get a copy of this message | ||
ID: 33292
Updated by: sniper@php.net
Reported By: doug_craig at charter dot net
-Status: Open
+Status: Feedback
-Bug Type: Reproducible crash
+Bug Type: Apache related
Operating System: Win 2000 5.00.2195 sp4
PHP Version: 5CVS-2005-06-10 (dev)
New Comment:
Did you remember to replace ALL existing dlls and extensions?
PHP 5.1 is NOT binary compatible with previous versions..
Previous Comments:
------------------------------------------------------------------------
[2005-06-11 18:44:02] doug_craig at charter dot net
NOTE: the date on the snapshot that did not work is 6/11/2005 4:54PM
------------------------------------------------------------------------
[2005-06-11 18:42:53] doug_craig at charter dot net
Tried the snapshot.
Apache fails to start with the following error:
Syntax error on line 194 of c:/program files/apache
group/apache/conf/httpd.conf: Cannot load c:/php/php5apache.dll into
server: (127) The specified procedure could not be found:
(1) the php5apache.dll exists
(2) httpd.conf has not changed
(3) php.ini is identical to previous PHP install
Uninstalled and reinstalled snapshot from 6/9/2005 6:44PM with no
changes to httpd or php.ini and Apache starts up fine (albeit with the
same reported error for apache_get_modules calls).
Something wrong with that snapshot.
------------------------------------------------------------------------
[2005-06-11 15:30:32] sniper@php.net
Please try using this CVS snapshot:
http://snaps.php.net/php5-latest.tar.gz
For Windows:
http://snaps.php.net/win32/php5-win32-latest.zip
------------------------------------------------------------------------
[2005-06-10 01:07:55] doug_craig at charter dot net
Description:
------------
Only modification from php.ini-recommended is to enable MySQL (and
changes made by PHP 5.0.4 Installer).
PHP installed as an Apache module.
Apache/1.3.33 (Win32)
Reproduce code:
---------------
<?php
print_r(apache_get_modules());
?>
Expected result:
----------------
Array
(
[0] => core
[1] => http_core
[2] => mod_so
[3] => sapi_apache2
[4] => mod_mime
[5] => mod_rewrite
)
Actual result:
--------------
No error report to Apache error.log
Windows error: Apache.exe - Application Error
for a memory reference that could not be read.
------------------------------------------------------------------------
--
Edit this bug report at http://bugs.php.net/?id=33292&edit=1