#33292 [Fbk->Opn]: apache_get_modules crashes

From: Date: Mon, 13 Jun 2005 16:05:01 +0000
Subject: #33292 [Fbk->Opn]: apache_get_modules crashes
References: 1  Groups: php.bugs 
Request: Send a blank email to php-bugs+get-80240@lists.php.net to get a copy of this message
ID: 33292 User updated by: doug_craig at charter dot net Reported By: doug_craig at charter dot net -Status: Feedback +Status: Open Bug Type: Apache related Operating System: Win 2000 5.00.2195 sp4 PHP Version: 5CVS-2005-06-10 (dev) New Comment: Stopped Apache service Uninstalled working 5.0.4 PHP Deleted C:\PHP tree Removed php.ini from C:\WINNT Confirmed no PHP DLLs in WINNT tree Unzipped snapshot (6/11/2005 4:54PM) into C:\PHP Copied php.ini-recommended to php.ini Set extension_dir to C:\PHP\ext in php.ini Uncommented extension=php_mysql.dll in php.ini Confirmed C:\PHP in PATH Confirmed PHPRC=C:\PHP in environment PHP LoadModule, AddModule, AddType in httpd.conf Started Apache service... running phpinfo() confirms 5.1.0-dev is running apache_get_modules() call gives same error :( One conclusion: PHP supplied 5.0.4 installer should not be used for 5.1 Other information: The only non-default Apache module I'm loading is PHP I am running localhost most of the time for Apache I am running Apache from port 888 For kicks I reconfig'd for standard port. Same error. Previous Comments: ------------------------------------------------------------------------ [2005-06-13 11:23:59] sniper@php.net You don't need to use some installer, just plain copy the files..with apache, you can set the path to the libphp5.dll in the httpd.conf yourself.. ------------------------------------------------------------------------ [2005-06-12 00:02:18] doug_craig at charter dot net For reinstalls I do an uninstall and then delete C:\PHP then unzip to C:\PHP. I'm not copying any dlls outside of the PHP tree and my extension_dir is set to C:\PHP\ext The only extension I'm specifying is MySQL Is php-5.0.4-installer.exe (what I'm using) compatible with 5.1, or does it copy any dlls outside of PHP tree? Thanks for your help. ------------------------------------------------------------------------ [2005-06-11 19:47:08] sniper@php.net Did you remember to replace ALL existing dlls and extensions? PHP 5.1 is NOT binary compatible with previous versions.. ------------------------------------------------------------------------ [2005-06-11 18:44:02] doug_craig at charter dot net NOTE: the date on the snapshot that did not work is 6/11/2005 4:54PM ------------------------------------------------------------------------ [2005-06-11 18:42:53] doug_craig at charter dot net Tried the snapshot. Apache fails to start with the following error: Syntax error on line 194 of c:/program files/apache group/apache/conf/httpd.conf: Cannot load c:/php/php5apache.dll into server: (127) The specified procedure could not be found: (1) the php5apache.dll exists (2) httpd.conf has not changed (3) php.ini is identical to previous PHP install Uninstalled and reinstalled snapshot from 6/9/2005 6:44PM with no changes to httpd or php.ini and Apache starts up fine (albeit with the same reported error for apache_get_modules calls). Something wrong with that snapshot. ------------------------------------------------------------------------ The remainder of the comments for this report are too long. To view the rest of the comments, please view the bug report online at http://bugs.php.net/33292 -- Edit this bug report at http://bugs.php.net/?id=33292&edit=1

« previous php.bugs (#80240) next »