Bug #17325: PHP Fails to run when using Apache 2.036, unresolved symbols
| From: | webmaster at vdhosting dot com | Date: | Tue, 21 May 2002 01:09:43 +0000 |
| Subject: | Bug #17325: PHP Fails to run when using Apache 2.036, unresolved symbols | ||
| Groups: | php.bugs | ||
| Request: | Send a blank email to php-bugs+get-8047@lists.php.net to get a copy of this message | ||
From: webmaster@vdhosting.com
Operating system: FREEBSD 4.1.1 STABLE
PHP version: 4.2.1
PHP Bug Type: Apache2 related
Bug description: PHP Fails to run when using Apache 2.036, unresolved symbols
I compiled standard Apache-2.0.35, then downloaded
php-4.2.1, compiled it just with --with-mysql and
--with-apxs2=/usr/local/apache2/bin/apxs
After sucessful make install, I tried to run
/usr/local/apache2/bin/httpd, which resulted in this error:
Syntax error on line 177 of
/usr/local/apache2/conf/httpd.conf:
Cannot load /usr/local/apache2/modules/libphp4.so into
server: /usr/local/apache2/modules/libphp4.so: Undefined
symbol "pthread_getspecific"
--
Edit bug report at http://bugs.php.net/?id=17325&edit=1
--
Fixed in CVS: http://bugs.php.net/fix.php?id=17325&r=fixedcvs
Fixed in release: http://bugs.php.net/fix.php?id=17325&r=alreadyfixed
Need backtrace: http://bugs.php.net/fix.php?id=17325&r=needtrace
Try newer version: http://bugs.php.net/fix.php?id=17325&r=oldversion
Not developer issue: http://bugs.php.net/fix.php?id=17325&r=support
Expected behavior: http://bugs.php.net/fix.php?id=17325&r=notwrong
Not enough info: http://bugs.php.net/fix.php?id=17325&r=notenoughinfo
Submitted twice: http://bugs.php.net/fix.php?id=17325&r=submittedtwice
register_globals: http://bugs.php.net/fix.php?id=17325&r=globals