Bug #17325 Updated: PHP Fails to run when using Apache 2.036, unresolved symbols
| From: | thuresson at coe dot tsuniv dot edu | Date: | Tue, 28 May 2002 19:41:51 +0000 |
| Subject: | Bug #17325 Updated: PHP Fails to run when using Apache 2.036, unresolved symbols | ||
| References: | 1 | Groups: | php.bugs |
| Request: | Send a blank email to php-bugs+get-8793@lists.php.net to get a copy of this message | ||
ID: 17325
Updated by: thuresson@coe.tsuniv.edu
Reported By: webmaster@vdhosting.com
Status: Open
Bug Type: Apache2 related
Operating System: FREEBSD 4.1.1 STABLE
PHP Version: 4.2.1
New Comment:
I successfully compiled Apache 2.0.36/PHP 4.3.0 dev on RedHat 7.2
Apache
./configure --prefix=/usr/local/apache2 --enable-modules=most
--enable-so
PHP
./configure --prefix=/usr/local/php430 --enable-ftp
--with-apxs2=/usr/local/apache2/bin/apxs
httpd.conf
LoadModule php4_module modules/libphp4.so
AddType application/x-httpd-php .php
I failed similar to previous comments when trying to install it the
same way on FreeBSD 4.4
./apachectl start
Syntax error on line 230 of
/usr/local/apache2/conf/httpd.conf:
Cannot load /usr/local/apache2/modules/libphp4.so into
server: /usr/local/apache2/modules/libphp4.so: Undefined
symbol "pthread_getspecific"
./apachectl start: httpd could not be started
Previous Comments:
------------------------------------------------------------------------
[2002-05-22 07:44:29] stimpy@broekiemedia.nl
I'm using FreeBSD 4.5, Apache-2.0.35 for freebsd 4.5,
mysql-3.23.49-unknown-freebsdelf4.4-i386
I compiled with --with-mysql=/usr/local/mysql
--with-apxs2=/usr/local/apache2/bin/apxs
httpd.conf contains:
LoadModule php4_module modules/libphp4.so
AddType application/x-httpd-php .php
And also I get this error:
Failed to start apache :
Syntax error on line 217 of /usr/local/apache2/conf/httpd.conf:
Cannot load /usr/local/apache2/modules/libphp4.so into server:
/usr/local/apache2/modules/libphp4.so: Undefined symbol
"pthread_getspecific"
/usr/local/apache2/bin/apachectl start: httpd could not be started
I also posted this reply at http://bugs.php.net/bug.php?id=14594, but
then I found out it was closed...
------------------------------------------------------------------------
[2002-05-20 21:09:43] webmaster@vdhosting.com
I compiled standard Apache-2.0.35, then downloaded
php-4.2.1, compiled it just with --with-mysql and
--with-apxs2=/usr/local/apache2/bin/apxs
After sucessful make install, I tried to run
/usr/local/apache2/bin/httpd, which resulted in this error:
Syntax error on line 177 of
/usr/local/apache2/conf/httpd.conf:
Cannot load /usr/local/apache2/modules/libphp4.so into
server: /usr/local/apache2/modules/libphp4.so: Undefined
symbol "pthread_getspecific"
------------------------------------------------------------------------
--
Edit this bug report at http://bugs.php.net/?id=17325&edit=1