#33577 [NEW]: Cannot load /usr/local/apache/libexec/libphp5.so into server: /usr/local/apache
| From: | vert at cloud9 dot net | Date: | Tue, 05 Jul 2005 18:48:32 +0000 |
| Subject: | #33577 [NEW]: Cannot load /usr/local/apache/libexec/libphp5.so into server: /usr/local/apache | ||
| Groups: | php.bugs | ||
| Request: | Send a blank email to php-bugs+get-81416@lists.php.net to get a copy of this message | ||
From: vert at cloud9 dot net
Operating system: Fedora Core 3
PHP version: 5.0.4
PHP Bug Type: Apache related
Bug description: Cannot load /usr/local/apache/libexec/libphp5.so into server: /usr/local/apache
Description:
------------
I am aware that several people have posted similar issues with the above
mentioned error, but none of the fixes I've tried seem to work.
Running:
Apache 1.3.33
OpenSSL 0.9.6
Trying to compile PHP 5.0.4. Configure input:
./configure --with-apxs='/usr/local/apache/bin/apxs' --with-gettext
--with-openssl='/usr/local/ssl/' --enable-ftp
--with-imap='/usr/local/imap-2004e/' --with-imap-ssl
--with-mysql='/usr/local/mysql' --with-dom
--with-mysqli='/usr/local/mysql/bin/mysql_config' --with-mcrypt
--with-iconv --enable-mbstring=all --enable-mbregex --with-gd
--with-mime-magic --with-zlib
What is strange is the exact same configuration works on the PHP dev
versions. However, another bug is preventing me from using it (not being
able to pass references or something, supposedly was fixed in later CVS
versions but still did not work for me... in fact, it worked previously
but suddenly one day, stopped.).
As directed in another post, I have added /usr/local/ssl to my ld.so.conf
file and yes, I did run ldconfig. That doesn't work either. Apache just
refuses to start. The exact error is:
[root@carc php-5.0.4]# /usr/local/apache/bin/apachectl configtest
Syntax error on line 209 of /usr/local/apache/conf/httpd.conf:
Cannot load /usr/local/apache/libexec/libphp5.so into server:
/usr/local/apache/libexec/libphp5.so: undefined symbol:
OpenSSL_add_all_algorithms
When I try compiling without SSL, I get a whole slew of OTHER errors. But
I still need SSL anyways for my setup.
Can someone please shed some light on this? Thanks.
--
Edit bug report at http://bugs.php.net/?id=33577&edit=1
--
Try a CVS snapshot (php4): http://bugs.php.net/fix.php?id=33577&r=trysnapshot4
Try a CVS snapshot (php5.0): http://bugs.php.net/fix.php?id=33577&r=trysnapshot50
Try a CVS snapshot (php5.1): http://bugs.php.net/fix.php?id=33577&r=trysnapshot51
Fixed in CVS: http://bugs.php.net/fix.php?id=33577&r=fixedcvs
Fixed in release: http://bugs.php.net/fix.php?id=33577&r=alreadyfixed
Need backtrace: http://bugs.php.net/fix.php?id=33577&r=needtrace
Need Reproduce Script: http://bugs.php.net/fix.php?id=33577&r=needscript
Try newer version: http://bugs.php.net/fix.php?id=33577&r=oldversion
Not developer issue: http://bugs.php.net/fix.php?id=33577&r=support
Expected behavior: http://bugs.php.net/fix.php?id=33577&r=notwrong
Not enough info: http://bugs.php.net/fix.php?id=33577&r=notenoughinfo
Submitted twice: http://bugs.php.net/fix.php?id=33577&r=submittedtwice
register_globals: http://bugs.php.net/fix.php?id=33577&r=globals
PHP 3 support discontinued: http://bugs.php.net/fix.php?id=33577&r=php3
Daylight Savings: http://bugs.php.net/fix.php?id=33577&r=dst
IIS Stability: http://bugs.php.net/fix.php?id=33577&r=isapi
Install GNU Sed: http://bugs.php.net/fix.php?id=33577&r=gnused
Floating point limitations: http://bugs.php.net/fix.php?id=33577&r=float
No Zend Extensions: http://bugs.php.net/fix.php?id=33577&r=nozend
MySQL Configuration Error: http://bugs.php.net/fix.php?id=33577&r=mysqlcfg