#33577 [Opn->Bgs]: Cannot load /usr/local/apache/libexec/libphp5.so into server: /usr/local/apache
| From: | sniper@php.net | Date: | Tue, 05 Jul 2005 20:56:14 +0000 |
| Subject: | #33577 [Opn->Bgs]: Cannot load /usr/local/apache/libexec/libphp5.so into server: /usr/local/apache | ||
| References: | 1 | Groups: | php.bugs |
| Request: | Send a blank email to php-bugs+get-81420@lists.php.net to get a copy of this message | ||
ID: 33577
Updated by: sniper@php.net
Reported By: vert at cloud9 dot net
-Status: Open
+Status: Bogus
Bug Type: Apache related
Operating System: Fedora Core 3
PHP Version: 5.0.4
New Comment:
Sorry, but your problem does not imply a bug in PHP itself. For a
list of more appropriate places to ask for help using PHP, please
visit http://www.php.net/support.php as this bug system
is not the
appropriate forum for asking support questions. Due to the volume
of reports we can not explain in detail here why your report is not
a bug. The support channels will be able to provide an explanation
for you.
Thank you for your interest in PHP.
Previous Comments:
------------------------------------------------------------------------
[2005-07-05 20:48:31] vert at cloud9 dot net
Description:
------------
I am aware that several people have posted similar issues with the
above mentioned error, but none of the fixes I've tried seem to work.
Running:
Apache 1.3.33
OpenSSL 0.9.6
Trying to compile PHP 5.0.4. Configure input:
./configure --with-apxs='/usr/local/apache/bin/apxs' --with-gettext
--with-openssl='/usr/local/ssl/' --enable-ftp
--with-imap='/usr/local/imap-2004e/' --with-imap-ssl
--with-mysql='/usr/local/mysql' --with-dom
--with-mysqli='/usr/local/mysql/bin/mysql_config' --with-mcrypt
--with-iconv --enable-mbstring=all --enable-mbregex --with-gd
--with-mime-magic --with-zlib
What is strange is the exact same configuration works on the PHP dev
versions. However, another bug is preventing me from using it (not
being able to pass references or something, supposedly was fixed in
later CVS versions but still did not work for me... in fact, it worked
previously but suddenly one day, stopped.).
As directed in another post, I have added /usr/local/ssl to my
ld.so.conf file and yes, I did run ldconfig. That doesn't work either.
Apache just refuses to start. The exact error is:
[root@carc php-5.0.4]# /usr/local/apache/bin/apachectl configtest
Syntax error on line 209 of /usr/local/apache/conf/httpd.conf:
Cannot load /usr/local/apache/libexec/libphp5.so into server:
/usr/local/apache/libexec/libphp5.so: undefined symbol:
OpenSSL_add_all_algorithms
When I try compiling without SSL, I get a whole slew of OTHER errors.
But I still need SSL anyways for my setup.
Can someone please shed some light on this? Thanks.
------------------------------------------------------------------------
--
Edit this bug report at http://bugs.php.net/?id=33577&edit=1