#33533 [Fbk->Opn]: PDO_ODBC: Segmentation Fault with selecting informix text column
| From: | scott dot barnett at thuringowa dot qld dot gov dot au | Date: | Tue, 12 Jul 2005 03:57:05 +0000 |
| Subject: | #33533 [Fbk->Opn]: PDO_ODBC: Segmentation Fault with selecting informix text column | ||
| References: | 1 | Groups: | php.bugs |
| Request: | Send a blank email to php-bugs+get-81705@lists.php.net to get a copy of this message | ||
ID: 33533
User updated by: scott dot barnett at thuringowa dot qld dot gov dot au
Reported By: scott dot barnett at thuringowa dot qld dot gov dot au
-Status: Feedback
+Status: Open
Bug Type: PDO related
Operating System: CentOS 4.1 / Redhat Enterprise 4
PHP Version: 5CVS-2005-07-04
New Comment:
Yeah it was a clean build, and I definately have both extensions in
php.ini. Now that it's not a pear library, is there something I need to
add to my configure syntax to include pdo unixODBC support?
I've done a find -name pdo.so and it only shows up in the source tree
that I compiled PHP from. pdo_odbc.so also shows up in that tree.
Trying with the new snapshot, php -m shows up:
[PHP Modules]
ctype
date
dom
ftp
iconv
informix
ldap
libxml
mysql
odbc
pcre
PDO
pdo_sqlite
pgsql
posix
session
SimpleXML
sockets
SPL
SQLite
standard
tokenizer
xml
Previous Comments:
------------------------------------------------------------------------
[2005-07-12 05:36:44] wez@php.net
Sounds like you're missing an extension=pdo_odbc.so line from your
php.ini.
Installing over the top of an existing install is usually ok, provided
that you made a fresh, clean build for the new install.
------------------------------------------------------------------------
[2005-07-12 01:42:11] scott dot barnett at thuringowa dot qld dot gov
dot au
With snapshot 200507112030 using the ifx_ functions it comes back
with:
[Tue Jul 12 09:34:05 2005] [notice] child pid 2175 exit signal
Segmentation fault (11)
[Tue Jul 12 09:34:06 2005] [notice] child pid 2176 exit signal
Segmentation fault (11)
I'm having some difficulties with PDO now, it comes back with : "Failed
to connect:could not find driver". This is probably just a
misconfiguration problem on my end that I haven't managed to track down
yet.
Note: When I tryed the latest snapshot I just did a "make install" over
the top of the old one.
------------------------------------------------------------------------
[2005-07-08 21:14:32] wez@php.net
(those fixes are in PDO_ODBC only)
------------------------------------------------------------------------
[2005-07-08 21:09:23] wez@php.net
Please try using this CVS snapshot:
http://snaps.php.net/php5-latest.tar.gz
For Windows:
http://snaps.php.net/win32/php5-win32-latest.zip
I fixed a few things that might have resolved your problem; please try
the latest snapshot. Would be nice to hear back from you ASAP if it
doesn't work.
------------------------------------------------------------------------
[2005-07-04 03:35:14] scott dot barnett at thuringowa dot qld dot gov
dot au
Same problem with the latest snapshot.
I've setup pdo_odbc and I get the exact same symptoms, can select char
and int fields, but not text or blob. The error that comes up in
err_log is different though:
FATAL: emalloc(): Unable to allocate -2147483648 bytes
2147483648 is the maximum size of a text field. The most characters in
any of the tuples in the test table is about 30.
------------------------------------------------------------------------
The remainder of the comments for this report are too long. To view
the rest of the comments, please view the bug report online at
http://bugs.php.net/33533
--
Edit this bug report at http://bugs.php.net/?id=33533&edit=1