ID: 33533
Updated by: wez@php.net
Reported By: scott dot barnett at thuringowa dot qld dot gov dot au
-Status: Open
+Status: Feedback
Bug Type: PDO related
Operating System: CentOS 4.1 / Redhat Enterprise 4
PHP Version: 5CVS-2005-07-04
New Comment:
Remove old stuff:
- pear uninstall pdo_odbc
- pear uninstall pdo
Grab a PHP 5.1 snapshot from http://snaps.php.net:
- Extract it
- cd into the dir
- ./configure <your usual options> --with-pdo-odbc=unixODBC
- make
- make install
then test it
Previous Comments:
------------------------------------------------------------------------
[2005-07-12 07:40:11] scott dot barnett at thuringowa dot qld dot gov
dot au
Rightio, it was user error. I did an strace and I had php.ini in the
wrong place, I've corrected it. Previously I configured the extensions
dir as a configure option and compiled my own pdo.so and pdo_odbc.so so
it worked ok.
"php -m" shows up PDO and pdo_sqlite. I thought PDO was going to be
included with PHP and therefore would be in the latest snapshot or do
you want me to get it from pear?
------------------------------------------------------------------------
[2005-07-12 06:20:34] scott dot barnett at thuringowa dot qld dot gov
dot au
Argh scratch the comment about the .so's being in the source tree.
They're there because I put them there when I was compiling the
previous version.
Just for good measure I completely removed apache from the system,
removed the source trees, and started from scratch. Still experiencing
the same problem though.
Tried
pear install -f PDO
pear install -f PDO_ODBC
"pear list" now shows up:
Installed packages:
===================
Package Version State
Archive_Tar 1.1 stable
Console_Getopt 1.2 stable
HTML_Template_IT 1.1 stable
Net_UserAgent_Detect 2.0.1 stable
PDO 0.3 beta
PDO_ODBC 0.2 beta
PEAR 1.3.5 stable
XML_RPC 1.3.1 stable
PDO still comes back with "Failed to connect:could not find driver"
------------------------------------------------------------------------
[2005-07-12 05:57:02] scott dot barnett at thuringowa dot qld dot gov
dot au
Yeah it was a clean build, and I definately have both extensions in
php.ini. Now that it's not a pear library, is there something I need to
add to my configure syntax to include pdo unixODBC support?
I've done a find -name pdo.so and it only shows up in the source tree
that I compiled PHP from. pdo_odbc.so also shows up in that tree.
Trying with the new snapshot, php -m shows up:
[PHP Modules]
ctype
date
dom
ftp
iconv
informix
ldap
libxml
mysql
odbc
pcre
PDO
pdo_sqlite
pgsql
posix
session
SimpleXML
sockets
SPL
SQLite
standard
tokenizer
xml
------------------------------------------------------------------------
[2005-07-12 05:36:44] wez@php.net
Sounds like you're missing an extension=pdo_odbc.so line from your
php.ini.
Installing over the top of an existing install is usually ok, provided
that you made a fresh, clean build for the new install.
------------------------------------------------------------------------
[2005-07-12 01:42:11] scott dot barnett at thuringowa dot qld dot gov
dot au
With snapshot 200507112030 using the ifx_ functions it comes back
with:
[Tue Jul 12 09:34:05 2005] [notice] child pid 2175 exit signal
Segmentation fault (11)
[Tue Jul 12 09:34:06 2005] [notice] child pid 2176 exit signal
Segmentation fault (11)
I'm having some difficulties with PDO now, it comes back with : "Failed
to connect:could not find driver". This is probably just a
misconfiguration problem on my end that I haven't managed to track down
yet.
Note: When I tryed the latest snapshot I just did a "make install" over
the top of the old one.
------------------------------------------------------------------------
The remainder of the comments for this report are too long. To view
the rest of the comments, please view the bug report online at
http://bugs.php.net/33533
--
Edit this bug report at http://bugs.php.net/?id=33533&edit=1