Bug #17467 Updated: xslt: Unable to initialize module

From: Date: Tue, 28 May 2002 11:51:52 +0000
Subject: Bug #17467 Updated: xslt: Unable to initialize module
References: 1  Groups: php.bugs 
Request: Send a blank email to php-bugs+get-8747@lists.php.net to get a copy of this message
ID: 17467 Updated by: sander@php.net Reported By: tim@zero-interactive.com -Status: Open +Status: Feedback Bug Type: XSLT related Operating System: Win 2K PHP Version: 4.2.1 New Comment: Make sure there are no duplicates of any php related file, like the files in the dlls folder and php4ts.dll. Previous Comments: ------------------------------------------------------------------------ [2002-05-28 01:36:57] tim@zero-interactive.com Strangely enough, the extension still loads and runs ok as far as I can tell. It's just those annoying popup messages that appear when the web server is started and the errors is generates in the event log. ------------------------------------------------------------------------ [2002-05-28 00:59:36] tim@zero-interactive.com Running Apache 2.0.36 with PHP 4.2.1 on Win 2K Pro doesn't allow you to load the xslt extension. PHP is running using the php4apache2 filter. The PHP distro is the windows zip binaries. This is the error that appears in the Windows Event log: Application popup: Warning : xslt: Unable to initialize module Module compiled with module API=20020429, debug=0, thread-safety=1 PHP compiled with module API=20010901, debug=0, thread-safety=1 These options need to match I have copied the dlls directory to the system32 dir and also have my extention_dir set to the correct position. The error appears everytime that I try to start apache. ------------------------------------------------------------------------ -- Edit this bug report at http://bugs.php.net/?id=17467&edit=1

« previous php.bugs (#8747) next »