Bug #17507: LDAP module fails to load

From: Date: Wed, 29 May 2002 15:23:36 +0000
Subject: Bug #17507: LDAP module fails to load
Groups: php.bugs 
Request: Send a blank email to php-bugs+get-8849@lists.php.net to get a copy of this message
From: haniotak@ucnet.uoc.gr Operating system: Windows 2000 Advanced Server PHP version: 4.2.1 PHP Bug Type: LDAP related Bug description: LDAP module fails to load Scenario: Default PHP 4.2.1 installation on win2k / apache (as a service, PHP installed as dynamically linked module). php-ini-recommended used with one change: the extensions_dir points to c:/php/extensions/ On enabling the php_ldap.dll extension (removed ';' ) and then restarting the apache service, I get this popup: -- START -- Warning: ldap: Unable to initialize module Module compiled with module API=20020429, debug=0,thread-safety=1 PHP compiled with module API=20010901,debug=0,thread-safety=1 These options need to match -- END -- Can make an educated guess about the nature of the problem, cannot suggest a real fix. Thanks in advance for your time. -- Edit bug report at http://bugs.php.net/?id=17507&edit=1 -- Fixed in CVS: http://bugs.php.net/fix.php?id=17507&r=fixedcvs Fixed in release: http://bugs.php.net/fix.php?id=17507&r=alreadyfixed Need backtrace: http://bugs.php.net/fix.php?id=17507&r=needtrace Try newer version: http://bugs.php.net/fix.php?id=17507&r=oldversion Not developer issue: http://bugs.php.net/fix.php?id=17507&r=support Expected behavior: http://bugs.php.net/fix.php?id=17507&r=notwrong Not enough info: http://bugs.php.net/fix.php?id=17507&r=notenoughinfo Submitted twice: http://bugs.php.net/fix.php?id=17507&r=submittedtwice register_globals: http://bugs.php.net/fix.php?id=17507&r=globals

« previous php.bugs (#8849) next »