#35619 [NEW]: libphp5.so not created

From: Date: Sat, 10 Dec 2005 05:11:39 +0000
Subject: #35619 [NEW]: libphp5.so not created
Groups: php.bugs 
Request: Send a blank email to php-bugs+get-90189@lists.php.net to get a copy of this message
From:             hellower at nate dot com
Operating system: AIX 5.3
PHP version:      5.1.1
PHP Bug Type:     Compile Failure
Bug description:  libphp5.so not created

Description:
------------
[apache 2.0.55 comiple]
# ./configure --prefix=/usr/local/apache --enable-so  --enable-rewrite
--enable-modules=proxy --enable-modules=rewrite --enable-modules=info
--enable-mods-shared=proxy --enable-mods-shared=rewrite
--enable-mods-shared=info
# make
# make install

[php 5.1.1 compile]
# ./configure --with-apxs2=/usr/local/apache/bin/apxs \
--with-oci8=/oracle \
--with-pdo-oci=/oracle \
--enable-pdo \
--with-pdo-sqlite \
--with-sqlite \
--enable-track-vars \
--enable-ftp \
--enable-track-vars  \
--disable-debug \
--disable-inline \
--without-mysql \
--enable-wddx \
--with-libxml-dir=/usr/local \
--enable-sigchild


# make

Build complete.
(It is safe to ignore warnings about tempnam and tmpnam).

# make install
Installing PHP SAPI module:       apache2handler
perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
        LC_ALL = (unset),
        LC__FASTMSG = "true",
        LC_MESSAGES = "",
        LANG = "en_US"
    are supported and installed on your system.
perl: warning: Falling back to the standard locale ("C").
/usr/local/apache/build/instdso.sh
SH_LIBTOOL='/usr/local/apache/build/libtool' libphp5.la
/usr/local/apache/modules
rm -f /usr/local/apache/modules/libphp5.so
/usr/local/apache/build/libtool --mode=install cp libphp5.la
/usr/local/apache/modules/
cp .libs/libphp5.a /usr/local/apache/modules/libphp5.a
cp .libs/libphp5.lai /usr/local/apache/modules/libphp5.la
libtool: install: warning: remember to run `libtool --finish
/usr/local/src/php-5.1.1/libs'
chmod 755 /usr/local/apache/modules/libphp5.so
chmod: /usr/local/apache/modules/libphp5.so: No such file or directory
apxs:Error: Command failed with rc=65536
.
make: *** [install-sapi] Error 1 !!!!!!!!!!!!!!!!!!!!!!!
sslgm11:/usr/local/src/php-5.1.1# 


-- 
Edit bug report at http://bugs.php.net/?id=35619&edit=1
-- 
Try a CVS snapshot (PHP 4.4): http://bugs.php.net/fix.php?id=35619&r=trysnapshot44
Try a CVS snapshot (PHP 5.1): http://bugs.php.net/fix.php?id=35619&r=trysnapshot51
Try a CVS snapshot (PHP 6.0): http://bugs.php.net/fix.php?id=35619&r=trysnapshot60
Fixed in CVS:                 http://bugs.php.net/fix.php?id=35619&r=fixedcvs
Fixed in release:             http://bugs.php.net/fix.php?id=35619&r=alreadyfixed
Need backtrace:               http://bugs.php.net/fix.php?id=35619&r=needtrace
Need Reproduce Script:        http://bugs.php.net/fix.php?id=35619&r=needscript
Try newer version:            http://bugs.php.net/fix.php?id=35619&r=oldversion
Not developer issue:          http://bugs.php.net/fix.php?id=35619&r=support
Expected behavior:            http://bugs.php.net/fix.php?id=35619&r=notwrong
Not enough info:              http://bugs.php.net/fix.php?id=35619&r=notenoughinfo
Submitted twice:              http://bugs.php.net/fix.php?id=35619&r=submittedtwice
register_globals:             http://bugs.php.net/fix.php?id=35619&r=globals
PHP 3 support discontinued:   http://bugs.php.net/fix.php?id=35619&r=php3
Daylight Savings:             http://bugs.php.net/fix.php?id=35619&r=dst
IIS Stability:                http://bugs.php.net/fix.php?id=35619&r=isapi
Install GNU Sed:              http://bugs.php.net/fix.php?id=35619&r=gnused
Floating point limitations:   http://bugs.php.net/fix.php?id=35619&r=float
No Zend Extensions:           http://bugs.php.net/fix.php?id=35619&r=nozend
MySQL Configuration Error:    http://bugs.php.net/fix.php?id=35619&r=mysqlcfg


Thread (2 messages)

« previous php.bugs (#90189) next »