#35073 [Asn->Fbk]: dba_open(test.db,n): Driver initialization failed for handler: db4: Invalid argu

From: Date: Mon, 12 Dec 2005 18:53:41 +0000
Subject: #35073 [Asn->Fbk]: dba_open(test.db,n): Driver initialization failed for handler: db4: Invalid argu
References: 1  Groups: php.bugs 
Request: Send a blank email to php-bugs+get-90298@lists.php.net to get a copy of this message
 ID:               35073
 Updated by:       helly@php.net
 Reported By:      marrtins at hackers dot lv
-Status:           Assigned
+Status:           Feedback
 Bug Type:         DBM/DBA related
 Operating System: Linux libc.2.3.2
 PHP Version:      5CVS-2005-11-03 (snap)
 Assigned To:      helly
 New Comment:

Can you please try with latest CVS version of PHP 5 again just to make
sure there wasn't some influence from some other thing i just fixed.


Previous Comments:
------------------------------------------------------------------------

[2005-11-03 22:50:30] helly@php.net

After reading this report several times i finally got to the point that
the problem is the usage of 4.3. Obviously there is another change in
the Sleepycat libs i have to check.

------------------------------------------------------------------------

[2005-11-03 22:36:29] sniper@php.net

Marcus, any ideas about this?


------------------------------------------------------------------------

[2005-11-03 22:21:36] marrtins at hackers dot lv

I found that fopen() part was not working by my fault. I was specified
open mode as c no w.

PHP example: http://paste.php.lv/2797/nonum
Result:
Warning: dba_open(test.db,n): Driver initialization failed for handler:
db4: Invalid argument in /data2/src/php5-200511030730/sapi/cli/test.php
on line 3

using db-4.3.29 (www.sleepycat.com)

I felt back to db-4.2.52 and recompiled now working fine. Is there
problem with db-4.3.29 package?

------------------------------------------------------------------------

[2005-11-02 22:38:51] marrtins at hackers dot lv

Description:
------------
As i migrated from php4 (4.3.9) to php5 (5.0.5, 5.0.4) every file
system function (fopen, dba_open, etc) cannot read/write files. Empty
file can be created - but can`t write any byte there.

Not using any loaders or encoders or similar modules.

When recompiled back to 4.3.9 all works fine. The same happens when
compiled as apache module - 4.3.9 works fine, 5.0.5 and 5.0.4 not.

Reproduce code:
---------------
Example can be found here - http://paste.php.lv/2785

compile script:
export LDFLAGS=-liconv && ./configure
make
make install

Linux libc-2.3.2

gcc -v
Reading specs from /usr/lib/gcc-lib/i486-slackware-linux/3.3.4/specs
Configured with: ../gcc-3.3.4/configure --prefix=/usr --enable-shared
--enable-threads=posix --enable-__cxa_atexit --disable-checking
--with-gnu-ld --verbose --target=i486-slackware-linux
--host=i486-slackware-linux
Thread model: posix
gcc version 3.3.4



Expected result:
----------------
Expecting file haha to be created with contents aa. Also db4
database with some entries.

Actual result:
--------------
fopen() reports `failed to open stream: Inappropriate ioctl for
device`

dba_open() reports Driver initialization failed for handler: db4




------------------------------------------------------------------------


-- 
Edit this bug report at http://bugs.php.net/?id=35073&edit=1


Thread (9 messages)

« previous php.bugs (#90298) next »