#35765 [Opn->Fbk]: fopen wrapper using invalid SIZE command
ID: 35765
Updated by: sniper@php.net
Reported By: jasonandtonya at gmail dot com
-Status: Open
+Status: Feedback
Bug Type: FTP related
Operating System: ALL
PHP Version: 5.1.1
New Comment:
Please try using this CVS snapshot:
http://snaps.php.net/php5.1-latest.tar.gz
For Windows:
http://snaps.php.net/win32/php5.1-win32-latest.zip
Previous Comments:
------------------------------------------------------------------------
[2005-12-21 18:28:40] jasonandtonya at gmail dot com
Description:
------------
when opening a file via ftp as an array
$logfile=fopen('ftp://example.com/filename.ext',"r");
it returns an error:
500 'SIZE filename.ext': command not understood and example.com is
running a Solaris default ftp daemon.
Looking at the latest version 5.1-latest, (I'm assuming that it is
using ftp_fopen_wrapper.c):
ftp_fopen_wrapper.c,v 1.85.2.2 2005/11/22 03:01:39
line 450:
/* find out the size of the file (verifying it exists) */
php_stream_printf(stream TSRMLS_CC, "SIZE %s\r\n",
resource->path);
Is there a reason that you are using a non-standard command SIZE for
verifying existance of the file?
Reproduce code:
---------------
$file=fopen('ftp://example.com/filename.ext',"r");
Expected result:
----------------
No error message when doing fopen
Actual result:
--------------
Warning: fopen('ftp://example.com/filename.ext')
[function.fopen]:
failed to open stream: FTP server reports 500 'SIZE filename.ext':
command not understood. in /patrh/to/htdocs/filename.php on line 3
------------------------------------------------------------------------
--
Edit this bug report at http://bugs.php.net/?id=35765&edit=1
Thread (5 messages)