ID: 35737
User updated by: jphml at videotron dot ca
Reported By: jphml at videotron dot ca
-Status: Feedback
+Status: Open
Bug Type: Apache2 related
Operating System: Linux
PHP Version: 5.1.1
New Comment:
I was not successful using CVS of 21-12-2005. I am using
CentOS 4.1 latest patch.
Previous Comments:
------------------------------------------------------------------------
[2005-12-22 17:22:22] jsuzuki at spamcop dot net
I had the same problem. The suggestion by sniper@php.net worked out.
Just as an FYI this was on a horribly out of Red Hat 7 with Apache
1.3.
-jack
------------------------------------------------------------------------
[2005-12-20 09:14:08] sniper@php.net
Please try using this CVS snapshot:
http://snaps.php.net/php5.1-latest.tar.gz
For Windows:
http://snaps.php.net/win32/php5.1-win32-latest.zip
And what OS is that exactly?
------------------------------------------------------------------------
[2005-12-20 04:26:09] jphml at videotron dot ca
Description:
------------
When tring to use Apache 2.0.55 with PHP 5.1.1 module
(libphp5.so) you get the following error on Apache startup
Syntax error on line 232 of /opt/fruity/conf/httpd.conf:
Cannot load /opt/fruity/modules/libphp5.so into
server: /opt/fruity/modules/libphp5.so: undefined symbol:
sqlite3SelectDelete
Your are then unable to start apache.
Here is my configure line for Apache:
./configure --prefix=/opt/fruity --enable-so
Here is my configure line for PHP 5.1.1:
./configure --prefix=/opt/fruity
--with-apxs2=/opt/fruity/bin/apxs --with-mysql
Here is my line about PHP in httpd.conf
LoadModule php5_module modules/libphp5.so
I tried the following:
- Apache 1.3.34 with PHP 5.1.1: same error
- Compile PHP 5.1.1 with --without-sqlite: Same error
- Compile PHP without --with-mysql: Same error
The following configuration works: Apache 2.0.55 and PHP
5.0.5 with the configure lines above. (In Apache 1.x use
--enable-module=so instead of --enable-so).
Note that both software were always compiled with
--prefix=/opt/fruity, I didn't tried without.
Expected result:
----------------
You expect that Apache will start without errors
Actual result:
--------------
When you start apache you get:
[root@toolbox bin]# ./apachectl start
Syntax error on line 232 of /opt/fruity/conf/httpd.conf:
Cannot load /opt/fruity/modules/libphp5.so into
server: /opt/fruity/modules/libphp5.so: undefined symbol:
sqlite3SelectDelete
and Apache doesn't start
------------------------------------------------------------------------
--
Edit this bug report at http://bugs.php.net/?id=35737&edit=1