ID: 35737
Comment by: kpankratz at gmail dot com
Reported By: jphml at videotron dot ca
Status: No Feedback
Bug Type: SQLite related
Operating System: Linux
PHP Version: 5.1.1
New Comment:
installing Tcl-devel package did not solve the problem.
Using --with-zlib removed the sqlite errors. The next module in the
list now produces the error.
ldd -d libphp5.so shows most of the modules as an undefined symbol.
PHP 5.1.2 source files, Apache 2.2.0 source files, OS = SLES 9 SP3
Previous Comments:
------------------------------------------------------------------------
[2006-01-28 23:08:34] vano at kolumbus dot fi
Try to install Tcl-devel package, because sqlite needs it. Then
recompile php.
OR
Re-configure pdo_sqlite/sqlite with "--disable-tcl" option (because it
is actually not needed for building the lirary). Then recompile php.
------------------------------------------------------------------------
[2006-01-11 03:54:23] george at gmarcotte dot com
http://snaps.php.net/php5.1-latest.tar.gz
has no effect still get the
error:
httpd: Syntax error on line 53 of /usr/local/apache2/conf/httpd.conf:
Cannot load /usr/local/apache2/modules/libphp5.so into server:
/usr/local/apache2/modules/libphp5.so: undefined symbol:
sqlite3SelectDelete
when I try to start the webserver. What is sqlite3SelectDelete? is
there some header files missing?
------------------------------------------------------------------------
[2006-01-05 11:23:24] james at e0ts dot com
Same with Debian 3.1
------------------------------------------------------------------------
[2006-01-04 19:23:21] esesen at o2 dot pl
exactly the same problem under slackware 10.2
------------------------------------------------------------------------
[2006-01-01 01:00:07] php-bugs at lists dot php dot net
No feedback was provided for this bug for over a week, so it is
being suspended automatically. If you are able to provide the
information that was originally requested, please do so and change
the status of the bug back to "Open".
------------------------------------------------------------------------
The remainder of the comments for this report are too long. To view
the rest of the comments, please view the bug report online at
http://bugs.php.net/35737--
Edit this bug report at http://bugs.php.net/?id=35737&edit=1