#31594 [Opn]: virtual(): Unable to include 'xxx' - error finding URI
| From: | per at computer dot org | Date: | Mon, 02 Jan 2006 09:11:22 +0000 |
| Subject: | #31594 [Opn]: virtual(): Unable to include 'xxx' - error finding URI | ||
| References: | 1 | Groups: | php.bugs |
| Request: | Send a blank email to php-bugs+get-91346@lists.php.net to get a copy of this message | ||
ID: 31594
User updated by: per at computer dot org
Reported By: per at computer dot org
Status: Open
Bug Type: Apache2 related
Operating System: linux 2.4.26
PHP Version: 5.*, 4.*
Assigned To: iliaa
New Comment:
Uh, part of the text-entries in this report seem to have disappeared?
For instance the one from Nov18 when the report was automatically
closed due to inactivity. What happened?
Previous Comments:
------------------------------------------------------------------------
[2006-01-02 09:55:18] per at computer dot org
Please, glib responses like that does you no service at all. Perhaps
you would care to note the following:
1) There is no problem in php 4.3.8, so something was clearly REGRESSED
in the following releases.
2) The problem is clearly caused by the PHP function setlocale().
------------------------------------------------------------------------
[2006-01-01 21:44:31] iliaa@php.net
This is not a PHP bug, the error comes direct from Apache, and
indicates that the request URL cannot be resolved.
------------------------------------------------------------------------
[2005-12-30 13:12:04] sniper@php.net
Per: the correct url is http://snaps.php.net/php5.1-latest.tar.gz
Ilia: Any ideas?
------------------------------------------------------------------------
[2005-12-30 11:31:36] per at computer dot org
OK, tried out http://snaps.php.net/php5.1-200512300930.tar.gz,
problem
still present:
part0+
Warning: virtual() [function.virtual]: Unable to include 'part1' -
error finding URI in
/srv/www/vhosts/www/htdocs/phpbug-31594/part0.phtml on line 11
If you still need me to try http://snaps.php.net/php5-latest.tar.gz let
me know when it's back.
FYI, the problem is actually very easy to reproduce - you shouldn't
have to wait for me to see if a particular release/patch has fixed the
problem.
------------------------------------------------------------------------
[2005-10-22 13:10:28] per at computer dot org
I should add - I am now getting a line with "no acceptable variant:"
for part1 in my apache2 error-log.
------------------------------------------------------------------------
The remainder of the comments for this report are too long. To view
the rest of the comments, please view the bug report online at
http://bugs.php.net/31594
--
Edit this bug report at http://bugs.php.net/?id=31594&edit=1