#36393 [Bgs]: OCI8 Fails to allow PHP to Load
| From: | peter dot wilton-jones at eads dot com | Date: | Tue, 14 Feb 2006 19:24:36 +0000 |
| Subject: | #36393 [Bgs]: OCI8 Fails to allow PHP to Load | ||
| References: | 1 | Groups: | php.bugs |
| Request: | Send a blank email to php-bugs+get-93261@lists.php.net to get a copy of this message | ||
ID: 36393
User updated by: peter dot wilton-jones at eads dot com
Reported By: peter dot wilton-jones at eads dot com
Status: Bogus
Bug Type: OCI8 related
Operating System: Win 2003 Server Enterprise
PHP Version: 5.1.2
New Comment:
This was my first thought but I am relatively confident that this is
already true as I installed the Admin option (500+MB) of the client
tools so the libraries should be installed and Oracle tools work so the
env variables should be correct.
I have used the exact same setup before on Apache (on another server)
and this works correctly.
I was wondering if it may be IIS6 with PHP.
Previous Comments:
------------------------------------------------------------------------
[2006-02-14 20:04:26] tony2001@php.net
Most likely you forgot to install OCI libraries or to set required
environment variables.
In both cases this is not PHP problem.
------------------------------------------------------------------------
[2006-02-14 19:57:34] peter dot wilton-jones at eads dot com
Description:
------------
When I enable php_oci8.dll under win 2003+IIS6+Oracle Client 9i, PHP
fails to load with no error message or Event logs.
I tried this with PHP 5.0.4 and 5.1.2 and both fail.
All websites with ISAPI module included fail to start but all other
work.
It then takes for ever to stop IIS.
Commenting out php_oci8.dll prevents this and all websites work
(without oracle links).
Oracle Client works, i.e. TNSPing and SQL+
Reproduce code:
---------------
N/A
Expected result:
----------------
N/A
Actual result:
--------------
N/A
------------------------------------------------------------------------
--
Edit this bug report at http://bugs.php.net/?id=36393&edit=1