#36436 [NEW]: DBA problem with Berkeley DB4

From: Date: Fri, 17 Feb 2006 22:42:52 +0000
Subject: #36436 [NEW]: DBA problem with Berkeley DB4
Groups: php.bugs 
Request: Send a blank email to php-bugs+get-93389@lists.php.net to get a copy of this message
From:             nobody at example dot org
Operating system: linux 2.6 AMD64
PHP version:      5.1.2
PHP Bug Type:     DBM/DBA related
Bug description:  DBA problem with Berkeley DB4

Description:
------------
Berkeley DB 4.2.52 fails with error when using PHP's dba_exists() and
dba_fetch() methods. Other dba handlers work fine.

Reproducable: always 



Reproduce code:
---------------
<?php

$db = dba_popen('test.db4', 'c', 'db4');
dba_insert('b0rk', 'b0rk', $db);
echo dba_fetch('b0rk', $db),"\r\n";

?>

Expected result:
----------------
b0rk

Actual result:
--------------
Notice: "DB_THREAD mandates memory allocation flag on DBT data..." 

Error string is from bdb.

-- 
Edit bug report at http://bugs.php.net/?id=36436&edit=1
-- 
Try a CVS snapshot (PHP 4.4): http://bugs.php.net/fix.php?id=36436&r=trysnapshot44
Try a CVS snapshot (PHP 5.1): http://bugs.php.net/fix.php?id=36436&r=trysnapshot51
Try a CVS snapshot (PHP 6.0): http://bugs.php.net/fix.php?id=36436&r=trysnapshot60
Fixed in CVS:                 http://bugs.php.net/fix.php?id=36436&r=fixedcvs
Fixed in release:             http://bugs.php.net/fix.php?id=36436&r=alreadyfixed
Need backtrace:               http://bugs.php.net/fix.php?id=36436&r=needtrace
Need Reproduce Script:        http://bugs.php.net/fix.php?id=36436&r=needscript
Try newer version:            http://bugs.php.net/fix.php?id=36436&r=oldversion
Not developer issue:          http://bugs.php.net/fix.php?id=36436&r=support
Expected behavior:            http://bugs.php.net/fix.php?id=36436&r=notwrong
Not enough info:              http://bugs.php.net/fix.php?id=36436&r=notenoughinfo
Submitted twice:              http://bugs.php.net/fix.php?id=36436&r=submittedtwice
register_globals:             http://bugs.php.net/fix.php?id=36436&r=globals
PHP 3 support discontinued:   http://bugs.php.net/fix.php?id=36436&r=php3
Daylight Savings:             http://bugs.php.net/fix.php?id=36436&r=dst
IIS Stability:                http://bugs.php.net/fix.php?id=36436&r=isapi
Install GNU Sed:              http://bugs.php.net/fix.php?id=36436&r=gnused
Floating point limitations:   http://bugs.php.net/fix.php?id=36436&r=float
No Zend Extensions:           http://bugs.php.net/fix.php?id=36436&r=nozend
MySQL Configuration Error:    http://bugs.php.net/fix.php?id=36436&r=mysqlcfg


Thread (3 messages)

« previous php.bugs (#93389) next »