#36436 [Opn->Asn]: DBA problem with Berkeley DB4
| From: | helly@php.net | Date: | Sat, 18 Feb 2006 15:58:17 +0000 |
| Subject: | #36436 [Opn->Asn]: DBA problem with Berkeley DB4 | ||
| References: | 1 | Groups: | php.bugs |
| Request: | Send a blank email to php-bugs+get-93401@lists.php.net to get a copy of this message | ||
ID: 36436
Updated by: helly@php.net
Reported By: nobody at example dot org
-Status: Open
+Status: Assigned
Bug Type: DBM/DBA related
Operating System: linux 2.6 AMD64
PHP Version: 5.1.2
-Assigned To:
+Assigned To: helly
Previous Comments:
------------------------------------------------------------------------
[2006-02-17 23:42:52] nobody at example dot org
Description:
------------
Berkeley DB 4.2.52 fails with error when using PHP's dba_exists() and
dba_fetch() methods. Other dba handlers work fine.
Reproducable: always
Reproduce code:
---------------
<?php
$db = dba_popen('test.db4', 'c', 'db4');
dba_insert('b0rk', 'b0rk', $db);
echo dba_fetch('b0rk', $db),"\r\n";
?>
Expected result:
----------------
b0rk
Actual result:
--------------
Notice: "DB_THREAD mandates memory allocation flag on DBT data..."
Error string is from bdb.
------------------------------------------------------------------------
--
Edit this bug report at http://bugs.php.net/?id=36436&edit=1