#36595 [NEW]: Error loading libphp5.so after adding Fileinfo module

From: Date: Thu, 02 Mar 2006 20:36:11 +0000
Subject: #36595 [NEW]: Error loading libphp5.so after adding Fileinfo module
Groups: php.bugs 
Request: Send a blank email to php-bugs+get-93859@lists.php.net to get a copy of this message
From: cstasonis at dmcos dot com Operating system: Redhat Fedroa Core 4 PHP version: 5.1.2 PHP Bug Type: Apache related Bug description: Error loading libphp5.so after adding Fileinfo module Description: ------------ After adding the Fileinfo PECL package to my PHP build I can no longer start apache. The following error is given Syntax error on line 241 of /opt/app/apache/conf/httpd.conf: Cannot load /opt/app/apache/libexec/libphp5.so into server: /opt/app/apache/libexec/libphp5.so: undefined symbol: fileinfo_module_entry /home/chris/bin/apachectl startssl: httpd could not be started The CLI version works fine however, including the use of the Fileinfo functions Reproduce code: --------------- apachectl startssl Expected result: ---------------- Apache starts Actual result: -------------- Apache fails to start -- Edit bug report at http://bugs.php.net/?id=36595&edit=1 -- Try a CVS snapshot (PHP 4.4): http://bugs.php.net/fix.php?id=36595&r=trysnapshot44 Try a CVS snapshot (PHP 5.1): http://bugs.php.net/fix.php?id=36595&r=trysnapshot51 Try a CVS snapshot (PHP 6.0): http://bugs.php.net/fix.php?id=36595&r=trysnapshot60 Fixed in CVS: http://bugs.php.net/fix.php?id=36595&r=fixedcvs Fixed in release: http://bugs.php.net/fix.php?id=36595&r=alreadyfixed Need backtrace: http://bugs.php.net/fix.php?id=36595&r=needtrace Need Reproduce Script: http://bugs.php.net/fix.php?id=36595&r=needscript Try newer version: http://bugs.php.net/fix.php?id=36595&r=oldversion Not developer issue: http://bugs.php.net/fix.php?id=36595&r=support Expected behavior: http://bugs.php.net/fix.php?id=36595&r=notwrong Not enough info: http://bugs.php.net/fix.php?id=36595&r=notenoughinfo Submitted twice: http://bugs.php.net/fix.php?id=36595&r=submittedtwice register_globals: http://bugs.php.net/fix.php?id=36595&r=globals PHP 3 support discontinued: http://bugs.php.net/fix.php?id=36595&r=php3 Daylight Savings: http://bugs.php.net/fix.php?id=36595&r=dst IIS Stability: http://bugs.php.net/fix.php?id=36595&r=isapi Install GNU Sed: http://bugs.php.net/fix.php?id=36595&r=gnused Floating point limitations: http://bugs.php.net/fix.php?id=36595&r=float No Zend Extensions: http://bugs.php.net/fix.php?id=36595&r=nozend MySQL Configuration Error: http://bugs.php.net/fix.php?id=36595&r=mysqlcfg

« previous php.bugs (#93859) next »