#36595 [Opn->Fbk]: Error loading libphp5.so after adding Fileinfo module
| From: | johannes@php.net | Date: | Thu, 02 Mar 2006 21:52:00 +0000 |
| Subject: | #36595 [Opn->Fbk]: Error loading libphp5.so after adding Fileinfo module | ||
| References: | 1 | Groups: | php.bugs |
| Request: | Send a blank email to php-bugs+get-93862@lists.php.net to get a copy of this message | ||
ID: 36595
Updated by: johannes@php.net
Reported By: cstasonis at dmcos dot com
-Status: Open
+Status: Feedback
Bug Type: Apache related
Operating System: Redhat Fedroa Core 4
PHP Version: 5.1.2
New Comment:
Please try using this CVS snapshot:
http://snaps.php.net/php5.1-latest.tar.gz
For Windows:
http://snaps.php.net/win32/php5.1-win32-latest.zip
Previous Comments:
------------------------------------------------------------------------
[2006-03-02 21:36:10] cstasonis at dmcos dot com
Description:
------------
After adding the Fileinfo PECL package to my PHP build I can no longer
start apache. The following error is given
Syntax error on line 241 of /opt/app/apache/conf/httpd.conf:
Cannot load /opt/app/apache/libexec/libphp5.so into server:
/opt/app/apache/libexec/libphp5.so: undefined symbol:
fileinfo_module_entry
/home/chris/bin/apachectl startssl: httpd could not be started
The CLI version works fine however, including the use of the Fileinfo
functions
Reproduce code:
---------------
apachectl startssl
Expected result:
----------------
Apache starts
Actual result:
--------------
Apache fails to start
------------------------------------------------------------------------
--
Edit this bug report at http://bugs.php.net/?id=36595&edit=1