#36620 [NEW]: Failing to start Apache after compiling PHP 4.3.8
| From: | bnatal at tsp dot sheridan dot com | Date: | Sun, 05 Mar 2006 18:32:45 +0000 |
| Subject: | #36620 [NEW]: Failing to start Apache after compiling PHP 4.3.8 | ||
| Groups: | php.bugs | ||
| Request: | Send a blank email to php-bugs+get-93936@lists.php.net to get a copy of this message | ||
From: bnatal at tsp dot sheridan dot com
Operating system: Solaris 2.8
PHP version: 4CVS-2006-03-05 (snap)
PHP Bug Type: XSLT related
Bug description: Failing to start Apache after compiling PHP 4.3.8
Description:
------------
I'm compiling PHP 4.3.8 on a web server running Apache/2.0.52 (i.e.
Solaris 2.8 system).
Trying to compile using. I already install and compiled Sablotron 1.0.2
from source.
./configure --enable-shared --with-pear
--with-apxs2=/usr/local/apache/bin/apxs --with-zlib \
--enable-ftp --enable-cli --enable-xslt --with-xslt-sablot
--with-curl=/usr/local --enable-force-cgi-redirect --enable-discard-path
\
--with-mssql=/usr/local --with-openssl=/usr/local/ssl
--with-mysql=/usr/local/mysql
--with-mysqli=/usr/local/mysql/bin/mysql_config \
--enable-calendar --prefix=/usr/local/apache/php
Here is the error message when attempting to restart Apache.
Syntax error on line 231 of /usr/local/apache/conf/httpd.conf:
Cannot load /usr/local/apache/modules/libphp4.so into server: ld.so.1:
/usr/local/apache/bin/httpd: fatal: relocation error: file
/usr/local/lib/libstdc++.so.6: symbol __eprintf: referenced symbol not
found
I've referenced the bug #33425, but did not have any luck after following
similiar steps. Please let me know how can I fix this issue.
--
Edit bug report at http://bugs.php.net/?id=36620&edit=1
--
Try a CVS snapshot (PHP 4.4): http://bugs.php.net/fix.php?id=36620&r=trysnapshot44
Try a CVS snapshot (PHP 5.1): http://bugs.php.net/fix.php?id=36620&r=trysnapshot51
Try a CVS snapshot (PHP 6.0): http://bugs.php.net/fix.php?id=36620&r=trysnapshot60
Fixed in CVS: http://bugs.php.net/fix.php?id=36620&r=fixedcvs
Fixed in release: http://bugs.php.net/fix.php?id=36620&r=alreadyfixed
Need backtrace: http://bugs.php.net/fix.php?id=36620&r=needtrace
Need Reproduce Script: http://bugs.php.net/fix.php?id=36620&r=needscript
Try newer version: http://bugs.php.net/fix.php?id=36620&r=oldversion
Not developer issue: http://bugs.php.net/fix.php?id=36620&r=support
Expected behavior: http://bugs.php.net/fix.php?id=36620&r=notwrong
Not enough info: http://bugs.php.net/fix.php?id=36620&r=notenoughinfo
Submitted twice: http://bugs.php.net/fix.php?id=36620&r=submittedtwice
register_globals: http://bugs.php.net/fix.php?id=36620&r=globals
PHP 3 support discontinued: http://bugs.php.net/fix.php?id=36620&r=php3
Daylight Savings: http://bugs.php.net/fix.php?id=36620&r=dst
IIS Stability: http://bugs.php.net/fix.php?id=36620&r=isapi
Install GNU Sed: http://bugs.php.net/fix.php?id=36620&r=gnused
Floating point limitations: http://bugs.php.net/fix.php?id=36620&r=float
No Zend Extensions: http://bugs.php.net/fix.php?id=36620&r=nozend
MySQL Configuration Error: http://bugs.php.net/fix.php?id=36620&r=mysqlcfg