#36620 [Opn->Bgs]: Failing to start Apache after compiling PHP 4.3.8
| From: | tony2001@php.net | Date: | Mon, 06 Mar 2006 14:08:14 +0000 |
| Subject: | #36620 [Opn->Bgs]: Failing to start Apache after compiling PHP 4.3.8 | ||
| References: | 1 | Groups: | php.bugs |
| Request: | Send a blank email to php-bugs+get-93964@lists.php.net to get a copy of this message | ||
ID: 36620
Updated by: tony2001@php.net
Reported By: bnatal at tsp dot sheridan dot com
-Status: Open
+Status: Bogus
Bug Type: XSLT related
Operating System: Solaris 2.8
PHP Version: 4CVS-2006-03-05 (snap)
New Comment:
So it looks like you have some problems with your building environment
and this is definitely not PHP problem.
Make sure that you're using gmake and GNU ld, it should work fine.
Previous Comments:
------------------------------------------------------------------------
[2006-03-06 14:52:54] bnatal at tsp dot sheridan dot com
Not really, I'm able to try it on a test Solaris box running the same
version of PHP and Apache and it works fine. But when I try to compile
using --enable-xslt --with-xslt-sablot and restart apache it errors on
this server. What can cause this error message to occur? Are there any
links that could be causing this problem?
Syntax error on line 231 of /usr/local/apache/conf/httpd.conf:
Cannot load /usr/local/apache/modules/libphp4.so into server: ld.so.1:
/usr/local/apache/bin/httpd: fatal: relocation error: file
/usr/local/lib/libstdc++.so.6: symbol __eprintf: referenced symbol not
found
------------------------------------------------------------------------
[2006-03-06 14:47:02] tony2001@php.net
Does the problem appear when you use GNU make and GNU ld ?
------------------------------------------------------------------------
[2006-03-05 20:23:43] bnatal at tsp dot sheridan dot com
I've tried your recommendations but continue to get the same error
message. Any other recommendations that I can try next?
------------------------------------------------------------------------
[2006-03-05 20:01:22] bnatal at tsp dot sheridan dot com
Installed / compiled the latest PHP version 4.4.2. However, I'm still
getting the error message below when trying to start apache.
Syntax error on line 231 of /usr/local/apache/conf/httpd.conf:
Cannot load /usr/local/apache/modules/libphp4.so into server: ld.so.1:
/usr/local/apache/bin/httpd: fatal: relocation error: file
/usr/local/lib/libstdc++.so.6: symbol __eprintf: referenced symbol not
found
Any suggestions?
------------------------------------------------------------------------
[2006-03-05 19:35:59] bjori@php.net
Please try using this CVS snapshot:
http://snaps.php.net/php4-STABLE-latest.tar.gz
For Windows:
http://snaps.php.net/win32/php4-win32-STABLE-latest.zip
------------------------------------------------------------------------
The remainder of the comments for this report are too long. To view
the rest of the comments, please view the bug report online at
http://bugs.php.net/36620
--
Edit this bug report at http://bugs.php.net/?id=36620&edit=1