#36848 [NEW]: Cannot start Apache: libphp5.so is garbled
| From: | jtaylor at qrsdc dot com | Date: | Fri, 24 Mar 2006 15:56:56 +0000 |
| Subject: | #36848 [NEW]: Cannot start Apache: libphp5.so is garbled | ||
| Groups: | php.bugs | ||
| Request: | Send a blank email to php-bugs+get-94843@lists.php.net to get a copy of this message | ||
From: jtaylor at qrsdc dot com
Operating system: Redhat 9
PHP version: 5.1.2
PHP Bug Type: Apache2 related
Bug description: Cannot start Apache: libphp5.so is garbled
Description:
------------
I'm running Apache 2.2.0 on a Redhat 9 system and I am trying to install
PHP 5.1.2. Before doing a make install for PHP Apache was working
flawlessly; however, after installing PHP as an Apache DSO I get the
following error message when I try to restart Apache:
Syntax error on line 53 of /etc/httpd/conf/httpd.conf:
API module structure `php5_module' in file /etc/httpd/modules/libphp5.so
is garbled - perhaps this is not an Apache module DSO?
I have tried re-compiling PHP with several different options, none of
which produce different results.
Expected result:
----------------
Normal Apache operation.
Actual result:
--------------
Syntax error on line 53 of /etc/httpd/conf/httpd.conf:
API module structure `php5_module' in file /etc/httpd/modules/libphp5.so
is garbled - perhaps this is not an Apache module DSO?
--
Edit bug report at http://bugs.php.net/?id=36848&edit=1
--
Try a CVS snapshot (PHP 4.4): http://bugs.php.net/fix.php?id=36848&r=trysnapshot44
Try a CVS snapshot (PHP 5.1): http://bugs.php.net/fix.php?id=36848&r=trysnapshot51
Try a CVS snapshot (PHP 6.0): http://bugs.php.net/fix.php?id=36848&r=trysnapshot60
Fixed in CVS: http://bugs.php.net/fix.php?id=36848&r=fixedcvs
Fixed in release: http://bugs.php.net/fix.php?id=36848&r=alreadyfixed
Need backtrace: http://bugs.php.net/fix.php?id=36848&r=needtrace
Need Reproduce Script: http://bugs.php.net/fix.php?id=36848&r=needscript
Try newer version: http://bugs.php.net/fix.php?id=36848&r=oldversion
Not developer issue: http://bugs.php.net/fix.php?id=36848&r=support
Expected behavior: http://bugs.php.net/fix.php?id=36848&r=notwrong
Not enough info: http://bugs.php.net/fix.php?id=36848&r=notenoughinfo
Submitted twice: http://bugs.php.net/fix.php?id=36848&r=submittedtwice
register_globals: http://bugs.php.net/fix.php?id=36848&r=globals
PHP 3 support discontinued: http://bugs.php.net/fix.php?id=36848&r=php3
Daylight Savings: http://bugs.php.net/fix.php?id=36848&r=dst
IIS Stability: http://bugs.php.net/fix.php?id=36848&r=isapi
Install GNU Sed: http://bugs.php.net/fix.php?id=36848&r=gnused
Floating point limitations: http://bugs.php.net/fix.php?id=36848&r=float
No Zend Extensions: http://bugs.php.net/fix.php?id=36848&r=nozend
MySQL Configuration Error: http://bugs.php.net/fix.php?id=36848&r=mysqlcfg