#36848 [Opn->Fbk]: Cannot start Apache: libphp5.so is garbled
| From: | tony2001@php.net | Date: | Fri, 24 Mar 2006 21:46:22 +0000 |
| Subject: | #36848 [Opn->Fbk]: Cannot start Apache: libphp5.so is garbled | ||
| References: | 1 | Groups: | php.bugs |
| Request: | Send a blank email to php-bugs+get-94857@lists.php.net to get a copy of this message | ||
ID: 36848
Updated by: tony2001@php.net
Reported By: jtaylor at qrsdc dot com
-Status: Open
+Status: Feedback
Bug Type: Apache2 related
Operating System: Redhat 9
PHP Version: 5.1.2
New Comment:
What was your ./configure line?
Previous Comments:
------------------------------------------------------------------------
[2006-03-24 16:56:55] jtaylor at qrsdc dot com
Description:
------------
I'm running Apache 2.2.0 on a Redhat 9 system and I am trying to
install PHP 5.1.2. Before doing a make install for PHP Apache was
working flawlessly; however, after installing PHP as an Apache DSO I
get the following error message when I try to restart Apache:
Syntax error on line 53 of /etc/httpd/conf/httpd.conf:
API module structure `php5_module' in file
/etc/httpd/modules/libphp5.so is garbled - perhaps this is not an
Apache module DSO?
I have tried re-compiling PHP with several different options, none of
which produce different results.
Expected result:
----------------
Normal Apache operation.
Actual result:
--------------
Syntax error on line 53 of /etc/httpd/conf/httpd.conf:
API module structure `php5_module' in file
/etc/httpd/modules/libphp5.so is garbled - perhaps this is not an
Apache module DSO?
------------------------------------------------------------------------
--
Edit this bug report at http://bugs.php.net/?id=36848&edit=1