#37133 [Fbk->Opn]: PHP in FastCGI mode cannot connect to same Apache server using readfile()
| From: | ecarpenter at itex dot co dot za | Date: | Wed, 19 Apr 2006 11:04:02 +0000 |
| Subject: | #37133 [Fbk->Opn]: PHP in FastCGI mode cannot connect to same Apache server using readfile() | ||
| References: | 1 | Groups: | php.bugs |
| Request: | Send a blank email to php-bugs+get-95989@lists.php.net to get a copy of this message | ||
ID: 37133
User updated by: ecarpenter at itex dot co dot za
Reported By: ecarpenter at itex dot co dot za
-Status: Feedback
+Status: Open
Bug Type: CGI related
Operating System: SuSE Linux 10.0
PHP Version: 4.4.2
New Comment:
The only errors found in the error log refers to timeout waiting for a
reply. Note that the php server did not stop working and could handle
new requests and even requests while the suspect one is in progress.
Below are the errors found in the error_log:
[Wed Apr 19 12:54:41 2006] [error] [client 127.0.0.1] FastCGI: comm
with server "/srv/www/fcgi-bin/php-cgi" aborted: idle timeout (30 sec)
[Wed Apr 19 12:54:41 2006] [error] [client 127.0.0.1] FastCGI:
incomplete headers (0 bytes) received from server
"/srv/www/fcgi-bin/php-cgi"
[Wed Apr 19 12:54:41 2006] [error] [client 127.0.0.1] FastCGI: comm
with server "/srv/www/fcgi-bin/php-cgi" aborted: idle timeout (30 sec)
[Wed Apr 19 12:54:41 2006] [error] [client 127.0.0.1] FastCGI:
incomplete headers (0 bytes) received from server
"/srv/www/fcgi-bin/php-cgi"
Previous Comments:
------------------------------------------------------------------------
[2006-04-19 10:20:59] tony2001@php.net
What exactly is written in the error_log about it?
------------------------------------------------------------------------
[2006-04-19 10:12:49] ecarpenter at itex dot co dot za
I download the release, the same problem still exist.
I compiled PHP using the following settings:
/configure --prefix=/usr --datadir=/usr/share/php
--mandir=/usr/share/man --bindir=/usr/bin --libdir=/usr/share
--includedir=/usr/include --sysconfdir=/etc --with-_lib=lib
--with-config-file-path=/etc --with-exec-dir=/usr/lib/php/bin
--disable-debug --enable-inline-optimization --enable-memory-limit
--enable-magic-quotes --enable-safe-mode --enable-sigchild
--disable-ctype --disable-session --without-mysql --disable-cli
--without-pear --with-openssl --enable-force-cgi-redirect
--enable-fastcgi --bindir=/srv/www/cgi-bin
The output after running php -v
PHP 4.4.3-dev (cgi-fcgi) (built: Apr 19 2006 11:52:46)
Copyright (c) 1997-2006 The PHP Group
Zend Engine v1.3.0, Copyright (c) 1998-2004 Zend Technologies
------------------------------------------------------------------------
[2006-04-19 09:41:11] tony2001@php.net
Please try using this CVS snapshot:
http://snaps.php.net/php4-STABLE-latest.tar.gz
For Windows:
http://snaps.php.net/win32/php4-win32-STABLE-latest.zip
------------------------------------------------------------------------
[2006-04-19 07:43:28] ecarpenter at itex dot co dot za
Description:
------------
If PHP is running in FastCGI mode and the php script, test.php, is
being executed. The readfile() statement never returns.
Note that both scripts are on the same server!
This above was test was done running php as an apache module (mod_php)
and works 100%.
Reproduce code:
---------------
<?
//file test.php
readfile("http://localhost/info.php");
?>
<?
//info.php
phpinfo();
?>
Expected result:
----------------
The result generated by phpinfo() in info.php should be returned to
test.php. test.php should then echo the result and should be displayed
in the callee's browser
Actual result:
--------------
Http Error 500
------------------------------------------------------------------------
--
Edit this bug report at http://bugs.php.net/?id=37133&edit=1