#37133 [Fbk->Opn]: PHP in FastCGI mode cannot connect to same Apache server using readfile()
ID: 37133
User updated by: ecarpenter at itex dot co dot za
Reported By: ecarpenter at itex dot co dot za
-Status: Feedback
+Status: Open
Bug Type: CGI related
Operating System: SuSE Linux 10.0
PHP Version: 4.4.2
New Comment:
If I configure the PHP application as a normal CGI handler everything
works fine (just very slow)
-----------------
#Settings used to run as normal cgi
AddHandler php-cgi .php
Action php-cgi /cgi-bin/php
DirectoryIndex index.php
-----------------
#fastcgi settings to recreate the problem
ScriptAlias /fcgi-bin/ /srv/www/fcgi-bin/
FastCgiIpcDir /var/lib/apache2/fastcgi
<Directory "/srv/www/fcgi-bin">
AllowOverride None
Options +ExecCGI -Includes
Order allow,deny
Allow from all
</Directory>
FastCgiServer /srv/www/fcgi-bin/php-cgi
#FastCGIExternalServer /srv/www/fcgi-bin/php-cgi -host 127.0.0.1:8000
AddHandler php-fastcgi .php
Action php-fastcgi /fcgi-bin/php-cgi
DirectoryIndex index.php
Previous Comments:
------------------------------------------------------------------------
[2006-04-19 11:06:58] tony2001@php.net
I can't reproduce it.
Please try to execute the same code using PHP CLI.
------------------------------------------------------------------------
[2006-04-19 11:04:01] ecarpenter at itex dot co dot za
The only errors found in the error log refers to timeout waiting for a
reply. Note that the php server did not stop working and could handle
new requests and even requests while the suspect one is in progress.
Below are the errors found in the error_log:
[Wed Apr 19 12:54:41 2006] [error] [client 127.0.0.1] FastCGI: comm
with server "/srv/www/fcgi-bin/php-cgi" aborted: idle timeout (30 sec)
[Wed Apr 19 12:54:41 2006] [error] [client 127.0.0.1] FastCGI:
incomplete headers (0 bytes) received from server
"/srv/www/fcgi-bin/php-cgi"
[Wed Apr 19 12:54:41 2006] [error] [client 127.0.0.1] FastCGI: comm
with server "/srv/www/fcgi-bin/php-cgi" aborted: idle timeout (30 sec)
[Wed Apr 19 12:54:41 2006] [error] [client 127.0.0.1] FastCGI:
incomplete headers (0 bytes) received from server
"/srv/www/fcgi-bin/php-cgi"
------------------------------------------------------------------------
[2006-04-19 10:20:59] tony2001@php.net
What exactly is written in the error_log about it?
------------------------------------------------------------------------
[2006-04-19 10:12:49] ecarpenter at itex dot co dot za
I download the release, the same problem still exist.
I compiled PHP using the following settings:
/configure --prefix=/usr --datadir=/usr/share/php
--mandir=/usr/share/man --bindir=/usr/bin --libdir=/usr/share
--includedir=/usr/include --sysconfdir=/etc --with-_lib=lib
--with-config-file-path=/etc --with-exec-dir=/usr/lib/php/bin
--disable-debug --enable-inline-optimization --enable-memory-limit
--enable-magic-quotes --enable-safe-mode --enable-sigchild
--disable-ctype --disable-session --without-mysql --disable-cli
--without-pear --with-openssl --enable-force-cgi-redirect
--enable-fastcgi --bindir=/srv/www/cgi-bin
The output after running php -v
PHP 4.4.3-dev (cgi-fcgi) (built: Apr 19 2006 11:52:46)
Copyright (c) 1997-2006 The PHP Group
Zend Engine v1.3.0, Copyright (c) 1998-2004 Zend Technologies
------------------------------------------------------------------------
[2006-04-19 09:41:11] tony2001@php.net
Please try using this CVS snapshot:
http://snaps.php.net/php4-STABLE-latest.tar.gz
For Windows:
http://snaps.php.net/win32/php4-win32-STABLE-latest.zip
------------------------------------------------------------------------
The remainder of the comments for this report are too long. To view
the rest of the comments, please view the bug report online at
http://bugs.php.net/37133
--
Edit this bug report at http://bugs.php.net/?id=37133&edit=1
Thread (10 messages)