#37205 [Opn]: Serving binary content/images fails with "comm with server aborted" FastCGI err

From: Date: Tue, 02 May 2006 17:57:17 +0000
Subject: #37205 [Opn]: Serving binary content/images fails with "comm with server aborted" FastCGI err
References: 1  Groups: php.bugs 
Request: Send a blank email to php-bugs+get-96484@lists.php.net to get a copy of this message
 ID:               37205
 User updated by:  phpbugs at thequod dot de
 Reported By:      phpbugs at thequod dot de
 Status:           Open
 Bug Type:         CGI related
 Operating System: Ubuntu Linux
 PHP Version:      5CVS-2006-04-29 (CVS)
 Assigned To:      dmitry
 New Comment:

The problem only appears with a minimum of content in the 
page.

Therefor I've added "displaying 10000 numbers" to the test 
script, without this, it does not happen.

Also the point of failure goes more backward (displays 
more numbers), if you add additional whitespace (\n) 
between them.


Previous Comments:
------------------------------------------------------------------------

[2006-05-01 17:43:03] phpbugs at thequod dot de

There's no difference. In fact, no relevant file seems to 
have changed in the snapshot.

I've tried it though:
You can test it yourself on 
http://codeprobe.de/test/POST.php, where I've
put the 
reproduce-script from above.

------------------------------------------------------------------------

[2006-05-01 15:07:15] tony2001@php.net

Please try using this CVS snapshot:

  http://snaps.php.net/php5.1-latest.tar.gz
 
For Windows:
 
  http://snaps.php.net/win32/php5.1-win32-latest.zip



------------------------------------------------------------------------

[2006-04-29 17:40:33] phpbugs at thequod dot de

The current error in the Apache error log is:

(104)Connection reset by peer: FastCGI: comm with 
server "/XXX/fcgi-scripts/XXX/php5-fcgi-starter" aborted: 
read failed, referer: http://XXX

Sorry, I probably should have created a new bug for it.

------------------------------------------------------------------------

[2006-04-29 16:15:12] phpbugs at thequod dot de

Thank you. It's fixed indeed for those cases, but I just 
experienced a similar problem, when POSTing to any page 
I've found.

It outputs the following at the end of the generated HTML:
<fieldset>
<div class="label"><label for="blog_allowblogcss">Erlaube 
angepasste CSS Datei fr Blogs:</label></div>
<div class="input"><input name="blog_allowblogcss" 
type="checkbox" value<!DOCTYPE HTML PUBLIC "-//IETF//DTD 
HTML 2.0//EN">
<html><head>
<title>200 OK</title>
</head><body>
<h1>OK</h1>
<p>The server encountered an internal error or
misconfiguration and was unable to complete
your request.</p>
<p>Please contact the server administrator,
 webmaster@thequod.de and inform them of the time the 
error occurred,
and anything you might have done that may have
caused the error.</p>
<p>More information about this error may be available
in the server error log.</p>
<hr>
<address>Apache/2.0.54 (Ubuntu) mod_chroot/0.5 DAV/2 
mod_fastcgi/2.4.2 mod_jk2/2.0.4 mod_ssl/2.0.54 
OpenSSL/0.9.7g Server at www.hahler.de Port 443</address>
</body></html>


It can be reproduced here with this script:
-------------------------------
<?php

var_dump( $_POST );

?>

<form action="<?php echo $_SERVER['REQUEST_URI'] ?>" 
method="post">
        <input type="text" name="test_input" />
        <input type="submit" />
</form>

<?php

for( $i = 0; $i < 10000; $i++ )
{
        echo $i;
}
?>
-------------------------------

I'm using the latest CVS tag here (with your "real fix").

------------------------------------------------------------------------

[2006-04-26 11:09:26] dmitry@php.net

Fixed in CVS HEAD and PHP_5_1.

------------------------------------------------------------------------

The remainder of the comments for this report are too long. To view
the rest of the comments, please view the bug report online at
    http://bugs.php.net/37205

-- 
Edit this bug report at http://bugs.php.net/?id=37205&edit=1


Thread (12 messages)

« previous php.bugs (#96484) next »