#37205 [Opn]: Serving binary content/images fails with "comm with server aborted" FastCGI err

From: Date: Thu, 04 May 2006 04:02:59 +0000
Subject: #37205 [Opn]: Serving binary content/images fails with "comm with server aborted" FastCGI err
References: 1  Groups: php.bugs 
Request: Send a blank email to php-bugs+get-96569@lists.php.net to get a copy of this message
 ID:               37205
 User updated by:  phpbugs at thequod dot de
 Reported By:      phpbugs at thequod dot de
 Status:           Open
 Bug Type:         CGI related
 Operating System: Ubuntu Linux
 PHP Version:      5CVS-2006-04-29 (CVS)
 Assigned To:      dmitry
 New Comment:

I've just tried current PHP_5_1 CVS again, and it works.

I must have messed up the last time, without using my 
usual configure options.

Thank you.


Previous Comments:
------------------------------------------------------------------------

[2006-05-03 17:42:11] phpbugs at thequod dot de

I've just tried current CVS again, which includes some 
fixes for FastCGI, but now the simple php script mentioned 
above just times out!

Error log:

FastCGI: comm with 
server "/XXX/fcgi-scripts/XXX/php5-fcgi-starter" aborted: 
idle timeout (60 sec)
FastCGI: incomplete headers (0 bytes) received from 
server "/XXX/fcgi-scripts/XXX/php5-fcgi-starter"

------------------------------------------------------------------------

[2006-05-02 17:57:16] phpbugs at thequod dot de

The problem only appears with a minimum of content in the 
page.

Therefor I've added "displaying 10000 numbers" to the test 
script, without this, it does not happen.

Also the point of failure goes more backward (displays 
more numbers), if you add additional whitespace (\n) 
between them.

------------------------------------------------------------------------

[2006-05-01 17:43:03] phpbugs at thequod dot de

There's no difference. In fact, no relevant file seems to 
have changed in the snapshot.

I've tried it though:
You can test it yourself on 
http://codeprobe.de/test/POST.php, where I've
put the 
reproduce-script from above.

------------------------------------------------------------------------

[2006-05-01 15:07:15] tony2001@php.net

Please try using this CVS snapshot:

  http://snaps.php.net/php5.1-latest.tar.gz
 
For Windows:
 
  http://snaps.php.net/win32/php5.1-win32-latest.zip



------------------------------------------------------------------------

[2006-04-29 17:40:33] phpbugs at thequod dot de

The current error in the Apache error log is:

(104)Connection reset by peer: FastCGI: comm with 
server "/XXX/fcgi-scripts/XXX/php5-fcgi-starter" aborted: 
read failed, referer: http://XXX

Sorry, I probably should have created a new bug for it.

------------------------------------------------------------------------

The remainder of the comments for this report are too long. To view
the rest of the comments, please view the bug report online at
    http://bugs.php.net/37205

-- 
Edit this bug report at http://bugs.php.net/?id=37205&edit=1


Thread (12 messages)

« previous php.bugs (#96569) next »